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Laboratory 1 
 
Switched Local Area Networks  
 
Overview This Lab is designed to demonstrate the need for implementation of switches in the 
design of local area networks. In this Lab, the students will design a 16-station LAN using first a 
simple hub, and then a switch and two hubs. The performance of the local area network in the 
two scenarios will then be compared.  
 
Procedure 
 
Create a New Project 
 
In this first phase you will open and name your project and name the first simulation scenario. 
The first simulation scenario will consist of 16 networked stations (PCs) and one hub. In this 
first phase you will specify the geographic size of the network.  
 

1. Start the OPNET IT Guru Academic Edition → Choose New from the File menu 
2. Select Project and click OK →; Name the project <your email username>_Lab1 

(e.g. xy123_Lab1) →  Name the scenario OnlyHub; Click OK 
3. In the Startup Wizard:Initial Topology dialog box, make sure that Create Empty 

Scenario is selected → Click Next → Choose Office from the Network Scale List → 
Click Next three times → Click Finish.  

4. Close the Object Pallete dialog box.  
 
Create the Network  
 
To create our switched LAN:  
 

1. Select Topology → Rapid Configuration. From the drop-down menu choose Star 
and click OK.  

2. Click the Select Models button in the Rapid Configuration dialog box. From the Model 
List drop-down menu choose ethernet and click OK.  

3. In the Rapid Configuration dialog box, set the following six values: Center Node Model 
= ethernet16_hub, Periphery Node Model = ethernet_station, Link Model = 
10BaseT, Number =16, Y=50, and Radius = 42 → Click OK.  

 
Remember that 10BaseT link represents an Ethernet connection operating at 10Mbps.  
 

4. Right-click on node_16, which is the hub → Edit Attributes →Change the name 
attribute to Hub1 and click OK.  

5. Now that you have created the network, it should look like the network on Figure 
below.  
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Fig.1 

6. Make sure to save your project.  
Configure the network nodes 
 
Here you will configure the traffic generated by the stations.  
 

1. Right-click on any of the 16 stations (node_0 to node_15) → Select Similar Nodes. 
Now all stations in the network are selected.  

2. Right-click on any of the 16 stations → Edit Attributes.  
a. Check the Apply Changes to Selected Objects check box. This is important 

to avoid reconfiguring each node individually.  
3. Expand the hierarchies of the Traffic Generation Parameters attribute and the 

Packet Generation Arguments attribute → Set the following four values:  

 
      Fig 2  
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4. Click OK to close the attribute editing window. Save your project 

 
Note here that we have introduced a traffic generation at each node. The traffic model follows a 
well-known ON-OFF model, in which each node switches between On state in which the traffic 
is generated, and OFF state in which there is no traffic. The duration of ON and OFF states is 
random, and in this example follows exponential distribution. In this example, the duration of 
OFF state is 0. 
 
Choose Statistics 
 
To choose the statistics to be collected during the simulation: 

1. Right-click anywhere in the project workspace and select Choose Individual 
Statistics DES from the pop-up menu.  

2. In the Choose Results dialog box, choose the following 4 statistics: 
a. Ethernet Delay – this represents the end-to-end delay of all packets received 

by all the stations.  
b. Traffic Received (in packets/sec) by the traffic sinks across all nodes 
c. Traffic Sent (in packets/sec) by the traffic sources across all nodes 
d. Collision count is the total number of collisions encountered by the hub 

during packet transmissions.  
3. Click OK.  

 
Configure the Simulation 
 
Here we need to configure the duration of the simulation:  

1. Click on the Configure / Run Simulation button.  
2. Set the duration to be 2.0 minutes 
3. Click Apply and then Cancel 

 
Duplicate the Scenario 
 
The network we just created utilizes only one hub to connect the 16 stations. We need to 
create another network that utilizes a switch and see how this will affect the network 
performance. To do that we will create a duplicate of the current network.  
 

1. Select Duplicate Scenario from the Scenarios menu and give it the name 
HubAndSwitch → Click OK.  

2. Open the Object Palette by clicking on  Make sure that Ethernet is selected in the 
pull-down menu on the object palette.  

3. We need to place a hub and a switch in the new scenario. (they are circled in the figure 
below).  

4. To add the Hub, click its icon in the object palette → Move your mouse to the 
workspace → Click to drop the hub at a location you select. Right click to indicate you 
are done deploying hub objects 

5. Similarly, add the Switch 
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6. Close the Object Palette 
7. Right-click on the new hub → Edit Attributes → Change the name attribute to Hub2 

and click OK.  
8. Right-click on the switch → Edit Attributes → Change the name attribute to Switch 

and click OK 
9. Reconfigure the network of the HubAndSwitch scenario so that it looks like the 

following one.  

 
Fig 3. 

Hints:  
• To remove a link, select it and choose Cut from the Eidt menu (or simply hit 

the Delete key). You can select multiple links and delete them all at once.  
• To add a new link, use the 10BaseT link available in the Object Palette.  

 
10. Save the Project.  

 
 
Run the Simulation 
 
To run the simulation for both scenarios simultaneously:  
 

1. Select Manage Scenarios from the Scenarios menu.  
2. Change the values under the Results column to <collect> (or <recollect>) for both 

scenarios. Compare to the following figure.  
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Fig 4 

 
3. Click OK to run the two simulations. 
4. After the two simulations runs complete, one for each scenarios, click Close.  
5. Save your project.  

 
View the Results 
 
To view and analyze the results: 
 

1. Select Compare Results from the Results menu. (Or right click in the workspace).  
2. Change the drop-down menu in the lower-right part of the Compare Results dialog box 

from As Is to time_average.  
3. Select the Traffic Sent (packets/sec) statistics and click Show.  
4. Select the Traffic Received (packets/sec) statistics and click Show. 
5. Select the Delay (packets/sec) statistics and click Show. 
6. Select the Collision Count (packets/sec) statistics and click Show. 
7. On the resulting graph right-click anywhere on the graph area → Choose Add 

Statistics → Expand the hierarchies as shown below → Select the Collision Count 
statistics for Hub2 → Change As Is to time_average → Click Add.  

8. Save your project.  
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City University  
School of Engineering and Mathematical Sciences 
 
Laboratory 2 
 
RIP: Routing Information Protocol 
 
 
Objective: To use OPNET to analyse the performance of RIP, a routing protocol built on a 
distance-vector routing algorithm. To examine the formation and exchange of routing tables. To 
observe how RIP is affected by link failures.  
 
 
Procedure 
 
Create a New Project 
 

1. Start Opnet IT Guru Academic Edition ⇒ choose New from the File menu 
2. Select Project and click OK ⇒ Name the project <your student 

number>_EE2480_Lab2 and the scenario NO_Failure ⇒ click OK.  
3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty 

Scenario is selected ⇒ Click Next ⇒ select Campus from the Network Scale list ⇒ 
Click Next 3 times ⇒ click OK.  

 
 
Create and Configure the Network 
 
Initialize the network: 

1. The Object Palette dialog box should now be on top of your project workspace. If it is 
not there, click on the icon in the menu. Make sure that the internet_toolbox is 
selected from the pull-down menu on the object palette.  

2. Add to the project workspace the following objects from the palette: one 
ethernet_slip8_gtwy router and two 100BaseT_LAN objects.  

a. To add an object from the palette, click its icon in the object palette ⇒ move 
your mouse to the workspace ⇒ click to place the object ⇒ right-click to stop 
creating objects of that type.  

3. Use bidirectional 100BaseT links to connect the objects you just added as in Figure 1. 
Also, rename the objects as shown (right-click on the node ⇒ Set Name).  

4. Close the Object Palette dialog box.  
5. Save your project.  
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Figure 1 

 
Configure the Router: 

1. Right-click on Router1 ⇒ Edit Attributes ⇒ Reports 
a. IP Forwarding Table = Export at End of Simulation. This asks the router to 

export its routing table at the end of the simulation to the simulation log.  
b. RIP Routing Table = Export at End of Simulation 

2. Click Ok and then save the project.  
 
Add the remaining LANs: 

1. Highlight or select simultaneously (using shift + left-click) all 5 objects that you 
currently have in the project workspace (one router, two LANs, and two links). You can 
click-and-drag a box around the objects to do this.  

2. Press Ctrl+C to copy the selected objects and then Ctrl+V to paste them.  
3. Repeat Step 2 three times to generate three new copies of the objects and arrange 

them in a way similar to the following figure. Rename all objects as shown.  
4. Connect routers, as shown, using PPP_DS3 links. The PPP_DS3 link has data rate of 

44.736Mbps.  
 

 
Figure 2 
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Choose the Statistics 
 
To test the performance of the RIP protocol, we will collect the following statistics: 
 

1. Right-click anywhere in the project workspace and select Choose Individual 
Statistics from the pop-up menu.  

2. In the Choose Results dialog box, check the following statistics: 
a. Global Statistics ⇒ RIP ⇒ Traffic Sent (bits/sec) 
b. Global Statistics ⇒ RIP ⇒ Traffic Received (bits/sec) 
c. Nodes Statistics ⇒ Route Table ⇒ Total Number of Updates 

3. Click OK and then save your project.  
 
RIP traffic is the total amount of RIP update traffic in bits sent/received per second by all the 
nodes using RIP as the routing protocol in the IP interfaces in the node. Total number of 
updates is the number of times the routing table at this node gets updated (e.g. due to a new 
route addition, an existing route deletion, and/or a next hop update).  
 
Configure the Simulation 
 
Here we need to configure some of the simulation parameters: 

1. Click on   and the Configure Simulation window should appear.  
2. Set the duration to be 10.0 minutes 
3. On the right-side panel, click on Input ⇒ Global Attributes tab and change the 

following attributes:  
a. IP Dynamic Routing protocol = RIP. This sets the RIP protocol to be the 

routing protocol of all routers in the network.  
b. IP Interface Addressing Mode = Auto Addressed/Export. 
c. RIP Sim Efficiency = Disabled. If this attribute is enabled, RIP will stop after 

the “RIP Stop Time”. But we need the RIP to keep updating the routing table in 
case there is any change in the network (as we will see in the second 
scenario).  

4. Click Ok and save the project.  
 
 
Auto Addressed means that all IP interfaces are assigned IP addresses automatically during 
simulation. The class of addresses (A, B or C) is determined on the basis of the number of 
hosts in the designed network. Subnet masks assigned to these interfaces are the default 
subnet masks for that class.  
 
Export causes the auto-assigned IP interfaces to be exported to a file 
<net_name>ip_address.gdf that gets saved in the primary model directory.  
 
 
Duplicate The Scenario 
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In the network we just created, the routers will build their routing tables, and then they will not 
need to update them further because we did not simulate any node or link failures. In this 
second scenario we will simulate failure so that we can compare the behaviour of the routers in 
both cases.  
 

1. Select Duplicate Scenario from the Scenarios menu and name it Failure ⇒ Click 
OK.  

2. Open Object Palette by clicking the icon. Select the Utilities palette from the drop-
down menu.  

3. Add a Failure Recovery object to your workspace and make it Failure as shown ⇒ 
Close the Object Palette dialog box.  

 

 
Figure 4 

 
4. Right-click on the Failure object ⇒ Edit Attributes ⇒ Right-click on the Link 

Failure/Recovery Specification hierarchy ⇒ Select Edit ⇒ Put 1 in rows, as in 
figure below: 

 
This will “fail” the link between Router1 and Router2 200 seconds into the simulation.  

5. Click Ok and save the project.  

 
Figure 5 
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Run the Simulation 
 
To run the simulation for both scenarios simultaneously: 

1. Go to the Scenarios menu ⇒ Select Manage Scenarios.  
2. Change the values under the Results column to <collect> (or <recollect>) 

for both scenarios. Compare to the following figure.  

 
Figure 6 

 
3. Click Ok to run the two simulations.  
4. After the two simulation runs complete, one for each scenario, click Close ⇒ Save 

your project.  
 
View the Results 
 
Compare the Number of Updates: 
 

1. Select Compare Results from the Results menu.  
2. Change the drop-down menu in the right-lower part of the Compare Results dialog box 

to Stacked Statistics as shown.  
 

3. Select the Total Number of Updates statistics for Router1 and click Show.  
4. You should get two graphs, one for each scenario. Right-click on each and select 

Draw Style ⇒ Bar.  
 
 
Obtain the IP Addresses: 
 
Before checking the contents of the routing tables, we need to determine the IP address 
information for all interfaces in the current network. Recall that these IP addresses are 
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assigned automatically during simulation, and we set the global attribute IP Interface 
Addressing Mode to export this information to a file.  
 

1. From the File menu choose Model Files ⇒ Refresh Model Directories. This causes 
Opnet IT Guru to search the model directories and update the list of files.  

2. From the File menu choose Open ⇒ from the drop-down menu choose Generic Data 
File ⇒ select the <your student number>_EE2480_Lab2-NO_Failure-
ip_addresses file (the other file created from the Failure scenario should contain the 
same information ⇒ click OK.  

  
3. The gdf file should show the IP addresses assigned to the interface of Router1 in our 

network. The Subnet Mask associated with every interface indicates that the address 
of the subnetwork to which the interface is connected.  

4. Draw the topology of the network and write down the IP addresses associated with 
Router1as well as addresses assigned to each subnetwork. 

 
Compare the Routing Tables Content: 
 

1. To check the content of the routing tables in Router1 for both scenarios:  
a. Go to Results menu ⇒ Open Simulation Log ⇒ Expand the hierarchy on 

the left as shown below ⇒ click on the field COMMON ROUTE TABLE.  
 
2. Carry out the previous step for both scenarios.  

 
 
Lab Report: In your report present all obtained results and give detailed explanation.  
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Laboratory 3 
 
Network Design 
 
The objective of this lab is to demonstrate the basics of designing a network, taking into 
consideration the users, services, and locations of the hosts. 
 
Create a New Project 
 

1. Start OPNET IT Guru Academic Edition ⇒ Choose New from the File menu.  
2. Select Project and click OK ⇒ Name the project <your student number>_NetDesign 

and the scenario SimpleNetwork ⇒click Ok.  
3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty 

Scenario is selected ⇒ click Next ⇒ choose Miles from the Size drop-down menu and 
assign 1 for both X Span and Y Span ⇒ click Next twice ⇒ click OK 

 
Create and configure the Network 
 
Initialize the Network: 

1. The Object Palette dialog box should be now on the top of your project space. If it is 

not there open it by clicking  Make sure that the internet_toolbox is selected from 
the pull down menu on the object palette.  

2. Add to the project workspace the following objects from the palette: Application Config, 
Profile Config, and a subnet. Application Config is used to specify applications that will 
be used to configure users profiles. Profile Config describes the activity patterns of a 
user or group in terms of the applications used over a period of time. You must define 
the applications using the Application Config before using this object.  

a. To add an object from the palette, click on its icon in the object palette ⇒ 
move your mouse to the workspace ⇒ left-click to place the object. Right-click 
when finished. The workspace should contain the following three objects: 

 
 
Configure the services: 



 

 

Material for this Laboratory has been adapted from the book Network Simulation Experiments Manual, 
by Prof E Aboelela, Morgan Kaufmann 2003 

1. Right-click on Application Config node ⇒ Edit Attributes ⇒ Change the name attribute 
to Applications ⇒ Change the Application Definitions attribute to Default ⇒ Click OK.  

2. Right-click on the Profile Config node ⇒Edit Attributes ⇒ Change the name attribute 
to Profiles ⇒ Change the Profile Configuration attribute to Sample Profiles ⇒ Click 
OK.  

 
Sample Profiles provides patterns of applications employed by users such as 
engineers, researchers, salespeople, and multimedia users.  
 

Configure a subnet: 
1. Right-click on the subnet node ⇒ Edit Attributes ⇒ Change the name attribute to 

Engineering and click OK.  
2. Double-click on the Engineering node. You get an empty workspace, indicating that the 

subnet contains no objects.  
3. Open the Object Palette and make sure it is still set to internet_toolbox. 
4. Add the following items to the subnet workspace: 10BaseT LAN, ethernet16Switch, 

and a 10BaseT link to connect the LAN with the Switch ⇒ Close the palette.  
5. Right-click on the 10BaseT LAN node ⇒ Edit attributes ⇒ Change the name attribute 

to LAN ⇒observe that the Number of Workstations attribute has a value of 10. Click in 
the Value column for the Application: Supported Profiles attribute, and select Edit. You 
should get a table in which you should do the following: 

a. Set the number of rows to 1 
b. Set the Profile Name to Engineer. Note: Engineer is one of the “sample” 

profiles provided within the Profile Config object.  
c. Click OK twice.  

The object we just created is equivalent to a 10-workstation star topology LAN. The 
traffic generated from the users of this LAN resembles that generated by “engineers”.  

6. Rename the ethernet16Switch to Switch   
7. The subnet should look like the one in figure below.  

 

 
8. Save your project 

 
Configure All Departments: 
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1. Now you have completed the configuration of the Engineering Department subnet. To 

go back to the main project space, click the Go to the higher level button .  
2. Make three copies of the Engineering subnet we just created. Click on the Engineering 

node ⇒ From the Edit menu, select Copy ⇒from the Edit menu select Paste three 
times, placing the subnet in the workspace after each, to create the new subnets.  

3. Rename (right-click on the subnet and select Set Name) and arrange the subnets as 
shown below: 

 

 
 

4. Double-click the Research node ⇒ Edit the attributes of its LAN ⇒ Edit the value of 
the Application: Supported Profile attribute ⇒ Change the value of the Profile Name 
from Engineer to Researcher ⇒ Click OK twice ⇒go to the higher level by clicking the 

 button.  
5. Repeat step 4 with the Sales node and assign to its Profile Name the profile 

Salesperson.  
6. Repeat step 4 with the E-Commerce node and assign to its Profile Name the profile E-

Commerce Customer.  
7. Save the project .  

 
Configure the Servers: 
 
Now we need to implement a subnet that contains the servers. The servers have to support the 
applications defined in the profiles we deployed. You can double-check these applications by 
editing the attributes of our Profile node. Inspect each row under the Applications hierarchy, 
which in turn, is under the Profile Configuration hierarchy. You will see that we need servers 
that support the following applications: Web browsing, Email, Telnet, File Transfer, Database, 
and File Print.  
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1. Open the Object Palette and add a new subnet ⇒rename the new subnet to Servers 

⇒ double-click the Servers node to enter its workspace.  
2. From the Object Palette, add three ethernet_servers, one ethernet16_switch, and three 

10BaseT links to connect the servers with the switch.  
3. Close the Object Palette 
4. Rename the servers and the switch as follows: 

 

 
 

5. Right-click on each one of the above servers and Edit the value of the Application: 
Supported Services attribute.  

a. For the Web Server add four rows to support the following services: Web 
Browsing (Light HTTP1.1), Web Browsing (Heavy HTTP1.1), Email (Light) and 
Telnet Session (Light) 

b. For the File Server add two rows to support the following services: File 
Transfer (Light) and File Print (Light).  

c. For the Database Server add one row to support the following service: 
Database Access (Light).  

6. Go back to he project space by clicking the Go to the higher level button.  
7. Save the project 

 
Connect the Subnets: 
 
Now all subnets are ready to be connected together.  
 

1. Open the Object Palette and add four 100BaseT links to connect the subnets of the 
departments to the Servers subnet.  
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As you create each link, make sure that it is configured to connect the “switches” in 
both subnets to each other. Do this by choosing them from the drop-down menu as 
follows: 

 
 
 
 
 
 

2. Close the Object Palette.  
3. Now your network should resemble the following one:  
 

 
 

4. Save the project.  
 
Choose the Statistics 
 
To test the performance of our network we will collect one of the many available statistics as 
follows: 
 

1. Right-click anywhere in the project workspace and select Choose Individual Statistics 
from the pop-up menu.  

2. In the Choose Results dialog box, choose Global statistics => HTTP => Page 
Response Time (seconds). Page response time is the required time to retrieve the 
entire page. 

3. Click OK.  
 
 
Configure the Simulation 
 
Here we need to configure the duration of the simulation 
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1. Click on the Configure/Run Simulation button .  
2. Set the duration to be 30.0 minutes 
3. Press OK 

 
Duplicate the Scenario 
 
In the network we just created we assumed that there is no background traffic already in the 
links. In real networks, the links usually have some existing background traffic. We will create a 
duplicate of the SimpleNetwork scenario but with background utilisation in the 100BaseT links. 
Link utilisation is the percentage of the used link bandwidth.  
 

1. Select Duplicate Scenario from the Scenarios menu and give it the name BusyNetwork 
⇒ click OK.  

2. Select all the 100BaseT links simultaneously (click on all of them while holding the 
Shift key) ⇒ Right-click on anyone of them ⇒ Edit Attributes ⇒ Check the Apply 
Changes to Selected Objects check box.  

3. Click on the value of Background Load ⇒ Edit ⇒ Average Packet Size (bytes) => 
choose Ethernet for BOTH directions.  

4. For the Intensity (bps), choose Edit from the pop-up menu and enter the following 
variables 

 
 
 
 
 
 
 

 
 
 

 
 
 
 
 
 
 

5. Click OK 
6. Repeat step 4 and 5 for defining the background load in the opposite direction  
7. your window of background load table should look like below.  
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8. Save your project 
 
 
 
Run the Simulation 
 
To run the simulation for both scenarios simultaneously:  

1. Go to the Scenarios menu ⇒ Select Manage Scenarios.  
2. Change the values under the Results column to <collect> for both scenarios. Compare 

to the following figure.  
3.  

 
 

4. Click OK to run the two simulations.  
5. After the two simulation runs complete (one for each scenario), click Close.  
6. Save the project 
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View the Results 
 
To view and analyse the results: 

1. Select Compare Results from the Results menu 
2. Change the drop-down menu in the lower-right part of the Compare Results dialog box 

from As Is to time_average. 
 

3. Select the Page Response Time (seconds) statistics and click Show.  
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Laboratory 4 
 
Queuing Disciplines: Order of packet Transmission and Dropping 
 
The objective of this lab is to examine the effect of different queuing disciplines on packet 
delivery and delay for different services. 
view 
Create a New Project 
 
1. Start OPNET IT Guru Academic Edition � Choose New from the File menu. 
2. Select Project and click OK � Name the project <your initials>_Queues, and 
the scenario FIFO � Click OK. 
3. In the Startup Wizard: Initial Topology dialog box, make sure that Create Empty 
Scenario is selected � Click Next � Select Campus from the Network Scale 
list � Click Next three times � Click OK. 
 
Create and Configure the Network 
 
Initialize the Network: 
1. Open the Object Palette dialog box. Make sure that the internet_toolbox item is 
selected from the pull-down menu on the object palette. 
 

2. Add to the project workspace the following objects from the palette: Application 
Config, Profile Config, QoS Attribute Config, five ethernet_wkstn, one 
ethernet_server, and two ethernet4_slip8_gtwy routers.  
Note that The QoS Attribute Config node defines attribute configuration details for protocols 
supported at the IP layer. These specifications can be referenced by the individual nodes 
using symbolic names. It defines different queuing profiles such as FIFO, WFQ, priority 
queuing, and custom queuing. 
 

3. Connect both routers together with a bidirectional PPP_DS1 link. 
 

4. Connect the workstations and the server to the routers using bidirectional 
10Base_T links as shown. 
 

 
 
5. Rename the objects you added as shown and then save your project. 
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Configure the Applications: 
 
Application Config is used to specify applications that will be used to configure users 
profiles. 
 
1. Right-click on the Applications node � Edit Attributes � Expand the Application 
Definitions hierarchy � Set rows to 3 � Name the rows: FTP Application, Video 
Application, and VoIP Application.  

i) Go to the FTP Application row � Expand the Description hierarchy � Assign High 
Load to Ftp � Click on the High Load value and choose Edit from the drop-down 
menu � Assign Constant(10) to Inter-Request Time � Assign Constant(1,000,000) 
to File Size. Keep the Type of Service (ToS) as Best Effort (0). Press Enter twice. 
Note that Type of Service (ToS) is assigned to the IP packets and It represents a 
session attribute that allows packets to be provided the appropriate service in the IP 
queues.  

 
ii) Go to the Video Application row � Expand the Description hierarchy � Assign Low 

Resolution Video to Video Conferencing � Click on the Low Resolution Video 
value and choose Edit � Edit the value of the Type of Service field (the Configure 
TOS/DSCP window appears) � From the dropdown menu, assign Streaming 
Multimedia (4) to ToS �Press Enter twice.  

iii) Go to the VoIP Application row � Expand the Description hierarchy � Assign PCM 
Quality Speech to Voice. Click on PCM Quality Speech  and make sure that the ToS 
assigned to it is  Interactive Voice (6).  

 

2. Click OK and then save your project. 
 

Configure the Profiles: 
 

Profile Config describes the activity patterns of a user or group of users in terms of the applications 
used over a period of time.  
 

1. Right-click on the Profiles node � Edit Attributes � Expand the Profile Configuration 
hierarchy � Set rows to 3.  

i. Name and set the attributes of row 0 as shown: 

 
ii. Name and set the attributes of row 1 as shown in next page: 
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iii. Name and set the attributes of row 2 as shown below: 
 

 
 
2. Click OK and then save your project. 
 
Configure the Queues: 
We will keep the default queuing profiles that are defined in our Queues object. It is 
recommended that you check out the configuration of the FIFO, PQ, and WFQ 
profiles. 
 
Configure the Workstations and Servers: 
 
1. Right-click on the FTP Client � Edit Attributes � Expand the Application: Supported 
Profiles hierarchy � Set rows to 1 � Set Profile Name to FTP Profile � Click OK. 
2. Right-click on the Video Client � Edit Attributes � Expand the Application: Supported 
Profiles hierarchy � Set rows to 1 � Set Profile Name to Video Profile � Click OK. 
3. Right-click on the VoIP West � Edit Attributes.  

i) Expand the Application: Supported Profiles hierarchy � Set rows to 1 � Set 
Profile Name to VoIP Profile. 

ii) Edit the Application: Supported Services value � Set rows to 1 � Set Service 
Name to VoIP Application � Click OK twice. 

 
4. Right-click on the VoIP East � Edit Attributes.  
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i) Expand the Application: Supported Profiles hierarchy � Set rows to 1 � Set 
Profile Name to VoIP Profile. 

ii) Edit the Application: Supported Services value � Set rows to 1 � Set Service 
Name to VoIP Application � Click OK twice. 

 
5. Right-click on the FTP Server � Edit Attributes � Edit the Application: Supported 
Services value � Set rows to 1 � Set Service Name to FTP Application � Click OK twice. 
6. Right-click on the Video Server � Edit Attributes � Edit the Application: Supported 
Services value � Set rows to 1 � Set Service Name to Video Application � Click OK 
twice. 
7. Save your project. 
 
Configure the Routers: 
 
1. Click on the link connecting the East and West routers to select it � From the Protocols, 
menu choose IP → QoS → Configure QoS. 
2. Make sure the selected items are as shown in the following QoS Configuration 
dialog box � Click OK. 

 
 
Note: Since the Visualize QoS Configuration radio button is checked, the link is colored 
based on the QoS scheme used. 
3. Save your project. 
 
Choose the Statistics 
 
To test the performance of the applications defined in the network, we will collect one of the 
many available statistics as follows: 
1. Right-click anywhere in the project workspace and select Choose Individual Statistics 
from the pop-up menu.  
2. In the Choose Results dialog box, select the following global statistic: 

i) IP=>Traffic Dropped (packets/sec) 
ii) FTP=> Traffic received (packets/sec) 
iii) Video Conferencing => Traffic received (Bytes/sec) 
iv) Voice=> Packet Delay variation, Packet End-to-End delay, Traffic received (Bytes/sec) 

 
3. Click on the link that connects east Router to West Router. Right click and choose 
Individual DES statistics. Under the point-to-point hierarchy, choose (queuing delay ) 
4. Click OK and then save your project. 
 
 
Configure the Simulation 
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Here we need to configure the duration of the simulation: 

1. Click on and the Configure Simulation window should appear. 
2. Set the duration to be 200 seconds. 
3. Click Apply and then save your project. 
 
Duplicate the Scenario 
In the network we just created, we used the FIFO queuing discipline in the routers. To 
analyze the effect of different queuing disciplines, we will create two more scenarios to test 
the Priority Queuing (PQ) and Weighted Fair Queuing (WFQ) disciplines. 
 
A. Select Duplicate Scenario from the Scenarios menu and give it the name PQ � Click 
OK. 1. Click on the link connecting the East and West routers to select it � From the 
Protocols menu choose IP → QoS → Configure QoS.  
2. Make sure the selected items are as shown in the following QoS Configuration dialog box 
� Click OK. 

 
 
3. Save your project. 
 
B. Select Duplicate Scenario from the Scenarios menu and give it the name WFQ � Click 
OK. 
1. Click on the link connecting the East and West routers to select it � From the Protocols 
menu choose IP → QoS → Configure QoS.  
2. Make sure the Qos Scheme is set Weighted Fair Queuing and Qos profile is ToS Based � 
Click OK. 
3. Save your project. 
 
Run the Simulation 
To run the simulation for the three scenarios simultaneously: 
 
1. Go to the Scenarios menu � Select Manage Scenarios. 
2. Change the values under the Results column to <collect> (or <recollect>) for the three  
scenarios. Put the simulation period to 200 seconds for all scenarios  
3. Click OK to run the three simulations.  
4. After the simulation completes the three runs, one for each scenario, click Close. 
5. Save your project. 
 
 
View the Results 
 
To view and analyze the results: 
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1. Select Compare Results from the Results menu. 
 
2. Select the IP Traffic Dropped statistic and click Show. The resulting graph should 
resemble the one below. Note: The shown graph is the result of zooming into the region of 
interest on the original graph. 
 
3. Create the graph for Video Conferencing Traffic Received: 
 
4. Create the graph for Voice Traffic Received: 
 
5. Create graphs for Voice Packet End-to-End Delay and Voice Packet Delay Variation. 
 
6. Create graphs for Queuing Delay for West Router East Router link 
  
 
Note1: if the graph is not shown for one of the scenarios, there might be an overlap of the 
presented results) 
 
Note2: Zoom the graphs into the region of interests to get the best visualization 
 
---------------------------------------------------------------------------------------------------------------------------- 
 
Question 1: Explain and compare the three queuing disciplines 
 
Question 2: Analyze the graphs we obtained and explain the effect of queuing 
discipline on the performance of the three applications. 
 
Question 3: Name three reasons for dropping an IP packet by a router. Which queuing 
discipline has higher queuing delay in the simulation. Explain why?  
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LABORATORY 5 
 
IP ADDRESSING AND SUBNETTING 
 
Assessment: You need to produce a HANDWRITTEN report. The Report should be 
submitted with an appropriate cover page containing your name and the module name. The 
report should consist of answers to questions Q1 to Q4.  
 

1. Run Advanced Subnet Calculator from your Desktop. This simple software can 
calculate the number of subnets that can be built using specified addresses and 
specified subnet masks.  

 
2. In the Advanced Subnet Calculator window, press the Classfull Subnet Calculator 

tab. Type in a class C IP address (e.g. 192.168.123.144), and use the following 
subnet masks 255.255.255.0; 255.255.255.128; 255.255.255.192. In all cases, 
press Generate Subnets button. Note the host range and the subnet size of all 
subnets. Note the number of mask bits, number of subnets and number of host 
bits.  

 
3. Now in the same window use a class B IP address, e.g. 132.168.123.144 and 

repeat the process with subnet masks 255.255.0.0; 255.255.128.0; 255.255.255.0 
 
Q1) Explain the concept of subnetting and the concept of subnet masks. Why do 
we use subnetting? How do we know which bits are used to identify the network?  
 
Q2) Present and discuss the results in Lab report. Why is it possible to make two 
subnets when a class C address and subnet mask of 255.255.255.128 was used? 
What happens when 255.255.255.255 is used as a subnet mask? What is the 
difference in the results when class B address is used?  
 

4. Press the CIDR Calculator tab. Enter address 132.168.123.144. Choose 
CIDR subnet mask to be 15 bits long. Generate 4, 32, 128 and 2048 subnets. 
Note the number of subnet bits needed for each case. Note the Host range 
and the Subnet Size for each case.  

 
Q3) Explain the obtained results. 
 
Q4) Consider a router that interconnects three subnets: subnet 1, subnet 2, and 
subnet 3. Suppose all of the interfaces in each of these three subnets are required 
to have a prefix 223.1.17/24. Also suppose that subnet 1 is required to support up 
to 125 interfaces, and subnets 2 and 3 are each required to support up to 60 
interfaces. Provide three network addresses (of the form a.b.c.d/x) that satisfy 
these constraints. You can use Advanced Subnet Calculator to solve this problem. 


