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Course Schedule

• Lecture 1
• Introduction
• Software Overview
• Part Design and Sketching

• Lecture 2
• Product Structure and 

Assembly Modelling
• More advance Part Design

• Lecture 3
• Wireframe and Surface
• Drafting

• Lecture 4
• Finite Element Analysis
• Data Exchange
• Parameters and Formulas



Lecture 1

CATIA Overview

• CATIA v5 is an Integrated Computer Aided 
Engineering tool:
! Incorporates CAD, CAM, CAE, and other applications
! Completely re-written since CATIA v4 and still under development
! CATIA v5 is a native Windows application
! User friendly icon based graphical user interface
! Based on Variational/ Parametric technology
! Encourages design flexibility and design reuse
! Supports Knowledge Based Design



Lecture 1

CATIA v5 Philosophy

• A Flexible Modelling environment
! Ability to easily modify models, and implement design changes
! Support for data sharing, and data reuse

• Knowledge enabled
! Capture of design constraints, and design intent as well as final 

model geometry
! Management of non-geometric as well as geometric design 

information

• The 3D Part is the Master Model
! Drawings, Assemblies and Analyses are associative to the 3D 

parts.  If the part design changes, the downstream models with 
change too.



Lecture 1

CATIA v5 Applications

• Freestyle Shaper
• Digital Shape Editor
• Knowledgeware
• Photo Studio 
• 4D Navigator (including 

kinematics)
• Manufacturing
• Finite Element Analysis

• Product Structure
• Part Design
• Assembly Design
• Sketcher
• Drafting (Interactive and 

Generative)
• Wireframe and Surface



Lecture 1

CATIA User Interface

Menu Bar

View Toolbar

Application 
Tool BarFile Toolbar

Current 
Application

Online Help



Lecture 1

Interacting with CATIA (1)

• Selecting an Application
! Use the Start menu to select an 

application

• Working with Files
! Use the File menu to create, 

open, save and print



Lecture 1

Interacting with CATIA (2)

• Display Commands
! Fly Through
! Fit View
! Layer control
! Pan
! Rotate
! Zoom 
! Normal View
! Standard Views
! View Types: Shaded/ Hidden 

Line/ Wireframe/ User Defined

• Hide/ Show
! Hide
! Swap Visible Space

• Properties
! Display Characteristics for an 

object are set by selecting the 
entity, then pressing the right 
mouse button and selecting 
Properties from the menu



Manipulating the Display using the Mouse

Lecture 1

• Pan
! Press and hold the middle 

mouse button and move the 
mouse to pan

• Rotate
! Press and hold the middle 

mouse button then the left 
mouse button and move the 
mouse to rotate

• Zoom
! Press and hold the middle 

mouse button and click the left 
mouse button then move the 
mouse to zoom in and out

• Using the compass

• Drag the axes or planes of 
the compass to dynamically 
rotate the display

• Multi-select entities by 
holding down the Shift key



Lecture 1

More Common Commands

• Copy/ Paste
! Geometry entities can be 

copied and pasted from one 
part to another.

! Paste Special allows you to:
• Paste a complete copy with 

history
• Paste a linked copy
• Paste the result without 

linking
• Undo/ Redo

! Allows you to undo previous 
actions

! Redo repeats an action that has 
been undone

• Hide/ Show
! Allows you to temporarily hide 

entities from the display
! Hidden entities can be 

recovered by clicking on the 
“Swap visible space” icon, and 
then selecting the entity to 
make visible

• Update
! Used to update the part after 

modification



Lecture 1

The Specification Tree

• The Specification Tree is displayed on the 
left side of the screen while you are 
working

• Provides access to the history of how a 
part was constructed, and shows the 
product structure

• Product entities can be selected from the 
spec. tree or in the geometry area

• Parts can be modified by selecting them 
from the spec. tree.

• Click on + to open a tree branch
• Solid Parts are stored in the PartBody

branch of the Part tree



Lecture 1

Getting Help

• The online help library can be accessed by selecting 
the Help -> Contents, Index and Search command

• The Help home page provides a search facility, and 
allows you to browse by application.  

• Every CATIA task has a getting started guide 



Lecture 1
Getting Help from the CATIA 

Community

• For general information about CATIA from IBM and Dassault 
Systemes refer to:

www.catia.com

• For access to the database of known problems refer to:
http://service.boulder.ibm.com/support/catia.support/databases

• The CATIA operator’s exchange provides a forum for the 
exchange of ideas and advice about using CATIA at:

www.coe.org

• And look at Member Center -> Forum

http://www.catia.com/
http://www.coe.org/


Lecture 1

Part Design

• The Part Design application is used to create solid 
models of parts

• Solid parts are usually created from 2D profiles that 
are extruded or revolved to form a base feature

• The Part Design task is tightly integrated with a 2D 
sketching tool

• A library of features is provided to allow user to add 
additional details to a base part

• Parts can be modified by selecting their features in 
the specification tree

• Parts are stored in files with the extension .CATPart



Lecture 1

Part Design

• Base Features

! Pad 
! Pocket
! Shaft

• Reference Elements

! Point
! Line
! Plane

• Dress-up Features

! Fillets
! Chamfers

• Transformation Features

! Translation
! Rotation
! Mirror
! Pattern
! Scale

!Slot
!Hole
!Groove

!Draft Shell 
!Thickness



Lecture 1

Sketcher

• The sketcher is used to create 2D sketches of 
designs, and apply constraints to the sketched 
geometry

• The sketcher is now the main environment for 
developing 2D profiles that will be used to build solid 
models (but traditional 2D wireframe techniques are 
available in the Wireframe and Surface application)

• The sketcher provides a flexible environment for 
creating and modifying 2D geometry



Lecture 1

Sketcher

• E

• E

• G

ntering the sketcher
! Click on the Sketcher icon or 

select Start -> Mechanical 
Design -> Sketcher

xiting from the Sketcher
! Click on the Exit icon to leave 

the sketcher and return to the 
3D workspace

eometry Creation

• Geometry Operations

• Constraint  Creation

• Tools Toolbar

! Snap to point

! Construction Geometry

! Constraint



Lecture 1

Using the Sketcher

• The Sketcher is a parametric design tool
• It allows you to quickly draw the approximate shape 

of a design, and then assign constraints to complete 
the shape definition

• Constraints can be applied as:
! Driving Dimensions – dimensions that control 
the size of a geometric entity
! Geometric Constraints – geometric 
relationships such as parallel, perpendicular, 
tangent, collinear



Lecture 1

Sketching Example

1. Click on the Sketcher icon
2. Select the 2D plane to sketch 

on (may be a plane, or the face 
of an existing part), and the 
sketching window will appear

3. Sketch the profile

4. Apply constraints to define the 
exact geometry required

4. Click on the exit icon to quit the 
sketcher 

5. Sketch is transferred into the 
3D modelling environment



Lecture 1

Sketching Tips

• To edit an existing sketch ensure that you select the sketch from 
the specification tree, or select an element in the sketch.  (If you 
do not do this you will create a new sketch instead of modifying
the existing one)

• If the sketch goes purple while you are constraining it is over-
constrained.  Generally it is best to Undo the last constraint and 
examine existing constraints to find the problem before 
continuing

• Solids can only be created from sketches that form a single 
closed boundary

• The profile icon allows you to create complicated profiles 
including lines and arcs.  See the online help for more 
information



Creating a Solid Part from a Sketch
Lecture 1

1. Click on the Pad icon  to 
create an extruded part

2. Select the sketch containing 
the profile you want to 
extrude (note the sketch is 
treated as a single entity)

3. The Pad definition window 
will appear

4. Select the limit type from:
! Dimension

! Up To Next

! Up To Last

! Up To Plane

5. Type in the length if required

6. Check the extrude direction 
arrow

7. Click on OK to create the 
Part



Lecture 1

Working with Features

• The Part Design task uses intelligent design features

• The features contain information about their context as well as 
their shape

• For example a Hole feature can only be created once you have 
created a part body
! A hole feature requires an attachment face, and driving dimensions

! A hole is a negative feature – it is automatically subtracted from the main 
Part Body

• Other features include Pad, Revolve, Pocket, Groove, Thread, 
Rib, Slot, Stiffener

• When a new feature is added to a solid part it is automatically 
combined with the existing part  



Lecture 1

Modifying a Part

• All parts created in Part Design can be edited at any time in the 
life of the part

• The parameters used to create a feature can be accessed by 
double clicking on the feature definition in the product 
specification tree or on the part geometry

• For example to change the height of a pad you should double 
click on the pad node in the specification tree. 

• The original feature dialogue will appear on the screen

• Change the values and click on OK.

• When you have modified the feature parameters the part will 
automatically update.  The part turns red briefly to indicate that it 
is out of date



Lecture 2

Assembly Design

• The Assembly Design application allows you to 
create a product model from a number of separate 
parts

• The parts in a product assembly are not joined 
together, but assembled as they would be in a 
physical assembly

• The product assembly structure is hierarchical and 
allows you to model complex product relationships

• Constraints can be applied between the parts in 
assembly to define relationships between them



Lecture 2

Assembly Design

• Product Structure Tools

! Insert New Component
! Insert New Product
! Insert New Part
! Insert Existing Component
! Replace Component
! Reorder Tree
! Generate Numbers
! Load Components
! Unload Components
! Manage Representations
! Multi-Instantiation

• Move Toolbar

! Manipulate
! Snap
! Explode and Assembly

• Constraints Toolbar

! Coincidence
! Contact
! Offset
! Angular
! Anchor
! Fix Together



Lecture 2

Benefits of Assembly Modelling

• Support for reuse of standard parts
! Assembly design creates links to the master geometry definition, so 

multiple instantiations of parts can be efficiently created

! Design changes are automatically reflected in the assembly

! Model sizes are minimised because geometry files are not copied

• Management of inter-part relationships
! Mating Conditions

! Contact Constraints

• Development of Kinematics models
! Simple mechanisms analysis available



Lecture 2

Using the Product Structure Tree 

• The specification tree shows product 
structure information relating to the 
parts and sub-assemblies contained 
in an assembly
! In the example shown on the right the 

product is called Product1

! The product contains three components 
CRIC_FRAME, CRIC_BRANCH_3 and 
CRIC_BRANCH_1.

• The Product and the Components do 
not contain any geometry

! Geometry is stored in parts inside the 
Component definitions

! The Constraints Branch shows the 
constraints that have been created to 
define the relationships between the 
components in the product structure



Lecture 2

Steps for Creating an Assembly

1. Create a new CATProduct using File -> New -> 
Product.

2. Use the  Product Structure tools to lay out the main 
assembly structure

3. Use Insert Existing Component or Insert New 
Part to create geometry in the Assembly

4. Use Constraints to capture the design relationships 
between the various parts in the assembly



Lecture 2

Saving Assembly Information 

• Assembly information is stored in a file with the 
extension .CATProduct.

• The CATProduct file contains only information 
relating to the product assembly.

• The detailed geometric information about the parts in 
the assembly is referenced to the original .CATPart
files

Warning
! If you copy a.CATProduct file it will still point to the original part files

! To copy an entire assembly use File -> Save All As… , specify a 
new location for the .CATProduct file, then click on the Propagate
button.
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More Advanced Part Design

• Boolean Operations
• Transforming Parts
• Assigning Materials
• Calculating Mass Properties



Lecture 2

Using Boolean Operations



Lecture 2

Using Boolean Operations

• To use the traditional Boolean operations approach 
to solid modelling you must create multiple bodies 
within a part. 

• Create additional Bodies by selecting the function
Insert -> New Body

• Boolean operations (join, subtract, intersect) can only 
be applied between the main PartBody, and other 
bodies in the same Part 



Lecture 2

Transforming Parts

• Solid features can be transformed using the 
transform functions

• Features can be mirrored, translated, rotated and 
scaled

• Patterns are used to created rectangular or circular 
arrays of features 



Lecture 2

Assigning Materials

• To Assign a material click on the Materials Icon on 
the toolbar

• Select a material from the material library
• Click on the part you wish to assign the material to, 

then click on Apply Material and OK. The material 
will appear on the properties branch in the spec tree

• Note: You may need to change the option settings 
To make the parameters branch of the specification 
tree visible. To do this select 

Tools->Options->Infrastructure->Product Structure
Specification Tree -> Parameters

1.



Lecture 2

Calculating Mass Properties

• Select the node of the part you want to analyse in the 
specification tree

• Click on the Measure Inertia icon 
Or

• Select Properties from the popup menu on the right 
mouse button to see the properties form, select the 
Mass tab and view the properties:



Lecture 3

Wireframe and Surface

• The Wireframe and Surface task provides a more 
traditional CAD 3D modelling environment

• The Wireframe functionality allows you to create 
Wireframe points, lines and curves in 3D space, 
without using the constraint based approach of the 
sketcher

• The Surface functionality allows you to create smooth 
freeform surfaces by sweeping Wireframe curves 
through 3D space 

• Wireframe and Surface is integrated with the other 
CATIA applications allowing for hybrid surface and 
solid modelling



Lecture 3

Wireframe and Surface

• Wireframe Toolbar

! Create Point
! Create Line
! Create Plane
! Create Projections 
! Create Intersections
! Create Circle
! Create Spline
! Corner
! Create Parallel Curves
! Create Boundary Curves

• Surface Toolbar

! Extrude Surfaces
! Surface of Revolution
! Offset Surface
! Sweep Surface
! Create Filling Surface
! Loft Surface
! Blend Surface
! Extract Geometry



Lecture 3

Wireframe and Surface

• Operations Toolbar

! Join
! Split, Trim
! Transform

• Tools Toolbar

! Update
! Axis
! Work with Support
! Snap to Point
! Create Datum (deactivate History)

• Transformations Toolbar

! Translate
! Rotate
! Create Symmetry
! Scale
! Affinity (irregular scaling)



Lecture 3

Creating Wireframe Geometry

• Wireframe geometry can be created in 
3D space, or on a 2D plane (using a 
support)

• Each wireframe function has a number of 
different methods (e.g.a line can be 
created from point to point, or parallel to 
an existing line, or many other ways).

• Existing geometry can be selected by 
picking on the screen or selecting from 
the spec. tree

• Additional options may be available by 
pressing the right mouse button over the 
input box



Lecture 3

Creating Surface Geometry

• Surfaces are usually created 
using a wireframe skeleton

• For example the Loft function 
requires 2 or more cross 
section curves

• It also optionally accepts a 
number of guide curves that 
extend between the cross 
curves

• A spine curve can be used to 
define the shape of the loft



Using the Specification Tree with 
Wireframe and Surface

Lecture 3

• Wireframe and Surface Geometry 
is created in an “Open Body” 
within the Part definition

• Geometry in the open body is not 
“attached” to the main part

• New Open bodies can be created 
using the Insert -> Open Body 
command

• A part can contain both Open 
Body and Part Body information



Lecture 3
Wireframe and Surface –

Hints and Tips

• If you want to repeatedly use the same function (e.g. 
to create multiple points) double-click on the icon.  
The dialogue will remain open after you click on OK.

• It can be very useful to create planes to use as a 
support when creating geometry.  

• When creating surfaces take care that the underlying 
wireframe geometry is consistent, and curve 
endpoints are all matched

• When creating surfaces ensure that curve 
orientations are consistent 



Lecture 3

Solid – Surface Integration

• The Part Design Application 
provides a Surface Based 
Features toolbar to allow you 
create solid bodies from 
surface models.

• Solids created from surfaces 
are generally more difficult to 
modify that solids generated 
in part design

• The solid part maintains 
associativity to the surfaces 
it was generated from 

• Surface Based Features

! Split – Uses a surface to split a 
solid object 

! Thicken – Creates a solid body 
by “thickening” an existing 
surface

! Close Surface – Creates a 
Solid body from a closed set of 
surfaces 

! Sew Surface – Joins a surface 
to a solid body 
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Generative Drafting

• The Generative Drafting Application allows you to 
create engineering drawings from parts or 
assemblies

• Generative Drafting automatically lays out 
orthographic projections of a part onto a drawing 
sheet

• Traditional Drafting functions can be used to annotate 
the drawing layout

• Drawings are stored in files with the extension 
.CATDrawing



Lecture 3

Generative Drafting

• Views Toolbar

! Create a Front View (other 
views available underneath 
icon)

! Create a section view
! Create a detail view
! Create a Clipping View
! Create Views Via Wizard

• Automatic Dimension 
Creation

! Auto-dimension
! Semi-Automatic Dimensions



Lecture 3

Interactive Drafting

• Allows you to create engineering drawings without 
first creating a 3D part

• Provides 2D drawing functionality to create geometry 
layouts

• Provides dimension and dress-up facilities for 
drawing annotation

• Can be used to add additional information to a 
drawing created using Generative Drafting



Lecture 3

Interactive Drafting

• Geometry Creation

! Point
! Line
! Circle
! Arc
! Profile
! Curve
! Pre-Define Profiles

• Transformations Toolbar

! Translate, Rotate, Scale, Mirror

• Relimitations Toolbar

! Corner
! Chamfer
! Trim
! Break

• Annotation

! Text
! Symbols



Lecture 3

Interactive Drafting

• Dimensions Toolbar

! Create Dimension
! Create Tolerance

• Dress up Toolbar

! Centreline
! Thread
! Axis
! Fill
! Arrow
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Drafting Example

• Create a new 
Drawing 
using File -> 
New…

• Select the 
drawing 
Format and 
Scale

• The drawing sheet will 
appear on the screen
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Drafting Example

• Use File -> Open… to open the 
3D part you want to generate a 
drawing from

• It is useful to arrange the screen 
so that you can see both views 
before continuing

• Use the View Creation toolbar 
to create a new view

• Click on the Front View icon, 
then select a plane on the 3D 
model to specify the view 
orientation

• A preview of the view will 
appear in the corner of the 
3D window

• Click on the drawing sheet to 
generate the view
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Drafting Example

• You can generate 
orthographic projects from 
an existing view using the 
Projection View icon

• Sections and detail views 
can also be generated from 
existing views



Importing Geometry from External 
Systems

Lecture 4

• CATIA provides import translators for many standard geometry 
formats including
! IGES, STEP AP203, DXF/ DWG, 

• Use File -> Open to import an external file

• The options to control the import parameters are available in
! Tools -> Options -> Product -> External Formats (check)

• Imported CAD geometry does not contain any history 
information

• Check the online help for more information about the types of 
entities that can be translated



Exporting CATIA geometry to other 
CAD systems

Lecture 4

• CATIA provides export translators for a number of 
standard formats including:
! IGES, STEP AP203, DXF/ DWG, VRML, CGM

• Use File -> Save As… , then select the desired type 
in the Save As Type box to export a file in an 
external format

• Exported geometry does not have any history 
associated with it

• Check the online help for more information about the 
types of entities that can be translated
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Generative Part Structural Analysis

• Generative Part Structural Analysis allows you to 
perform a finite element analysis on a solid part

• It is highly automated and allows an analysis to be 
performed with the minimum of interaction from the 
user

• Generative Part Structural Analysis provides very 
limited mesh control, and can only be applied to solid 
geometry

• It is generally used as a “quick check” for structural 
analysis
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Generative Part Structural Analysis

• Mesh Specification Toolbar

! Local Mesh Size
! Create Connections
! Create Virtual Parts

• Equipment Toolbar

! Created distributed and lumped 
masses

• Restraints Toolbar

! Create Clamp
! Create Slider
! Create Ball Joint

• Loads Toolbar

! Create Pressure
! Create Distributed Force
! Create Acceleration
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Generative Part Structural Analysis

• Compute Toolbar

! Specify External Storage
! Compute Static Solution
! Compute Frequency Solution
! Compute Buckling Solution

• Image Toolbar

! Visualise Deformations
! Visualise Von Mises Stresses
! Visualise Displacements
! Visualise Principle Stresses

• Analysis Toolbar
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Steps for Performing an Analysis

1. Select the parts or features for analysis

2. Define any connections, attached parts and non-
structural masses

3. Specify loads and restraints acting on the part

4. Submit the job for analysis

5. Visualise Results
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Parameters and Formulas

• CATIA V5 contains a group of applications that 
provide CATIA Knowledgeware capabilities

• These tools allow you to perform design automation, 
and capture non-geometric information about a 
product 

• The most basic Knowledgeware tool is the 
Knowledge Advisor

• Using Knowledge advisor you can create parameters 
and relationships relating to parts



Lecture 3

Knowledge Advisor

• CATIA stores information about a part in form of  
parameters

• Formula function – allows you to create new 
parameters and create relationships between existing 
parameters.

• Rules function – allows you to define design rules 
relating to design parameters in a part or product 

• Parameters and Relations are displayed in the 
specification tree



Lecture 3

Knowledge Advisor Example

• This relations branch shows two formulas:

! The value of the diameter Radius.1 is set equal to 2* the diameter 
of Hole.1 in the part

! The value of the user defined parameter PadLength is set equal to 
the sum of the two limits on Pad.1
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