SCORG™ Setup for CFD Simulation of Twin Screw Machines with Simerics Inc. PUMPLINX® Solver

SCORG™ is the CFD grid generation tool for rotary twin screw machines. The tool includes additional modules for designing and editing rotor profiles, executing a thermodynamic calculation based on quasi 1D chamber models and generating the deforming working chamber grids for selected commercial CFD solvers. For more information on the product please visit the website: www.pdmanalysis.co.uk or refer to documentation help.

This guide lists the steps for setting up a CFD simulation for Twin Screw Compressor with SCORG™ and PUMPLINX r3.4.6 Solver. The user is expected to be familiar with screw machines, CFD and PUMPLINX® in order to be able to use these procedures. It is highly recommended that books on that topic are studied.

Refer SCORG™ Installation Guide V5.4 for system and hardware requirements.

Table of Contents
1 Introduction .................................................................................................................................................. 2
2 SCORG™ Project ..................................................................................................................................... 3
3 SCORG™ Mesh Generation ...................................................................................................................... 10
4 Pumplinx case setup ............................................................................................................................... 20
5 Pumplinx Solver Calculation .................................................................................................................... 26
6 Summary .................................................................................................................................................... 27
7 Bibliography ............................................................................................................................................... 27

1 Introduction

Screw Compressors are rotary positive displacement machines. Although the working principle of these machines is simple, the geometry of rotors which are in the form of multi-lobe helical screws meshing with each other, is making analysis by use of Computational Fluid Dynamics (CFD) challenging. The process starts when the lobes are engaged at one end, which creates continuous increase of the volume between the rotors and the casing which reduces pressure in the suction domain and draws the working fluid in. Further rotation of the rotors makes this volume between the rotors and the casing enclosed when the compression of fluid begins. This increases the pressure within the chamber. Further rotation exposes the pressurized fluid to the outlet port and the fluid is delivered (Stosic, et al., 2005). Similar process is occurring in other helical screw machines such as pumps, vacuum pumps, gear pumps, expanders, extruders and motors. The CFD is equally challenging in such machines due to sliding and stretching.

The main objectives of CFD simulations of a screw compressor are to:

a. Obtain the pressure field inside the rotor chamber and in the suction and discharge domains. Example shown in Figure 1-1.

b. Obtain the velocity fields in critical regions of the computational domain.

c. Obtain temperature fields in critical regions of the computational domain.

d. Obtain integral parameters of the machine such as power, mass flow rate, discharge temperature, torques on the rotor shafts, etc.

e. Obtain the loads and temperatures on boundaries with solid parts of the machine for further structural and thermal analysis.

![Figure 1-1 Pressure Variation diagram of a Twin Screw Compressor (Kovacevic, et al., 2007)](image-url)
This Tutorial will provide a step by step guide for the procedure to setup and execute a typical twin screw compressor, pump or motor simulation. An example of a dry air compressor with 3/5 lobe combination, L/D ratio of 1.6 and wrap angle 285 deg has been considered.

2 SCORG™ Project

- Launch SCORG™ on the Desktop.
- Select File → New

- Select N35_Template.spt → Open
Save the project in a new folder named TwinScrewPumplinxSetup → SCORG_Grid_Tutorial.spf

The GUI of SCORG™ in the figure below shows the mains items of the front panel.
In Units Tab, Select Length units as ‘m’. This selection has to be the same as the units in which input profile coordinates are available.

Go to Help → Tutorials → Folder opens
Copy the compressor rotor profile files → [35MaleProfile_P1.dat and 35FemaleProfile_P2.dat]
Copy the compressor suction and discharge port grids → [SCORG_CFX_Tutorial_Ports_V5.4.cfx]
Copy the CFX setup script → [SCORG_CFX_Tutorial_V5.4.ccl]
Paste these files in the working directory → TwinScrewCFXSetup

Go to User Profile → Browse and Select the Male Rotor Profile from working directory.

35MaleProfile_P1.dat

- Click ‘Yes’ to overwrite P1.dat.

- Similarly Select the Female Rotor Profile.

35FemaleProfile_P2.dat
Click Write To Default.

Click Refresh to view new profiles.

Inspect the Rotor Profile in the GUI for gaps in the tips, starting points of the profile indicated by the small yellow circles. Below is the required orientation.
Set Project Units to SI

Set the following Profile Parameters to get desired clearance size:

GAPI = 0.06mm
GAPR = 0.06mm
GAPA = 0.05mm

*Setting GAPI = 0.06 sets the minimum interlobe clearance as the GAPI.
Go to Geometry ➔ Set the following parameters:

Go to Thermodynamics ➔ Set the following parameters:

Save the Project.
3 SCORG™ Mesh Generation

SCORG™ is stand-alone numerical CAD-CFD interface used to generate a numerical mesh of rotating parts of a screw machine and to transfer it to a general finite volume numerical solver. The program generates a block structured hexahedral numerical grid for rotor flow domains, solid rotor domains, inlet and outlet ports.

Inputs Required

In this step the rotor domain mesh is generated in SCORG™. The inputs required for this mesh generation are: (Kovacevic, et al., 2007).

Control Parameters:

- Type of the machine.
- Number of mesh divisions along the lobe in circumferential direction.
- Number of mesh divisions in radial direction.
- Number of Angular divisions of the rotation.

Control Switches:

These inputs are used to specify the method used for Rotor Profile Input and the required mesh calculation options.

- Click Grid Module in the project tree
- In Mesh Type Size set:
  - Circumferential = 60
  - Radial = 8
  - Angular = 50
  - Profile (Rack) Generation – Numerical

Distribution Parameters:

These inputs are used for adaptation and distribution of the grid points on the boundaries of the domain and for smoothing of rack (Rack is the curve representing a rotor with infinite radius which uniquely separates the flow domains of the male and female rotors).

- Type of Distribution → Rotor to Casing
Meshing Parameters:

Meshing parameters provide control over the distribution of the internal mesh points in each cross section of the rotors.

- both the distribution and meshing parameters can be changed later

Start Grid Generation through a three step process as below.

Select Rack Refinement Points = 400 (Default)
Click Numerical Rack Generation

This operation produces the rack curve between the two profiles. It is required to be executed only once in the grid generation process.

Click Boundary Distribution Generation
Information about the progress of the selected activities in the meshing procedure is displayed in the output window. Any warning or error and their locations are indicated. If errors occur, it is important to manually tune the input parameters which will produce a mesh without errors. Graphically the mesh distribution in each section can be visualized and checked for any deviation from requirements. The detailed description of methods used for distribution, adaptation and generation of numerical mesh is available through the Help in the drop down menu.

▶ Inspect report and check that there are no distribution warnings listed

▶ Click Distribution Mesh to visually inspect the distribution in each cross section
In the Distribution Display → Select Quality Criteria = Error Cell

- Inspect all the distribution positions and ensure that 0 error are reported in each position.

- Click Rotor Grid Generation

- Inspect report and check that there are no grid errors listed
Click Rotor Grid 2D Mesh to visually inspect the grid in each cross section
► Click Quality Criteria → Error Cell and Inspect.

► Click Quality Criteria → Orthogonality and Inspect.
- Inspect the 3D mesh

- In Control Switches → Preprocessor Input File select → Pumplinx
- Set Vertex Files Start = 1
- Set Vertex Files End = 1

- Calculate Preprocessor Files Generation
With this the SCORG Project is complete and the Pumplinx setup can be started.

In the directory structure of SCORG Project → Grid → Output consists of Pumplinx folder.

- Copy files in this folders to the project working directory → TwinScrewPumplinxSetup
- These are Rotor grids and the Pumplinx Template Setup
The highlighted files are required for full setup.
4 Pumplinx case setup

- Launch Pumplinx
- Select Open → Select → [Setup_Tutorial_Compressor.spro]
- Save as [TwinScrew35_Compressor.spro]
- Click Screw Module → Inspect the Model Properties → Correct the speed to 8000 rpm.

- View Geometric Entities by Type:
Scan through each of the boundaries and inspect the Properties.

- **Axial1_male** and **Axial1_female** should form the Suction Interface with Suction Port’s *suction_mgi_screw*.
- **Axial2_male** and **Axial2_female** should form the Discharge Axial Interface with the Discharge Port’s *discharge_mgi_screw_axi*.
**Casing_male, Casing_female, discharge_mgi_screw_rad_1** and **discharge_mgi_screw_rad_2** should form the main interface.

**Properties:**

This type of interface has been specifically devised for handling screw compressors with combined Axial and Radial port openings. These could be at the Suction or Discharge. In the tutorial example the discharge port has a combined axial and radial port.

The variable `toln` is used to filter only the faces from the rotor casings that form interlobe areas.
Rotor_male has following properties inherited by from the Screw Module:

- Rotational Units: rpm
- Rotational Direction: Clockwise
- Rotational Speed: 8000
- Direction: [0 0 1]
- Center: [0 0 0]
- Output: Default

<table>
<thead>
<tr>
<th>Geometric Entities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundaries</td>
</tr>
<tr>
<td>Axial1_female</td>
</tr>
<tr>
<td>Axial1_male</td>
</tr>
<tr>
<td>Axial2_female</td>
</tr>
<tr>
<td>Axial2_male</td>
</tr>
<tr>
<td>Casing_female</td>
</tr>
<tr>
<td>Casing_male</td>
</tr>
<tr>
<td>Rotor_female</td>
</tr>
<tr>
<td>Interfaces</td>
</tr>
<tr>
<td>MGI01_Casing_female_Casing_male</td>
</tr>
<tr>
<td>MGI01_Casing_female_discharge_mgi_screw...</td>
</tr>
</tbody>
</table>

Rotor_female has following properties inherited by from the Screw Module:

- Rotational Units: RPM
- Rotational Direction: Counterclockwise
- Rotational Speed: 4000
- Direction: [0 0 1]
- Center: [0.093 0 0]
- Output: Default

<table>
<thead>
<tr>
<th>Geometric Entities</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boundaries</td>
</tr>
<tr>
<td>Axial1_female</td>
</tr>
<tr>
<td>Axial1_male</td>
</tr>
<tr>
<td>Axial2_female</td>
</tr>
<tr>
<td>Axial2_male</td>
</tr>
<tr>
<td>Female_Rotor</td>
</tr>
<tr>
<td>Casing_female</td>
</tr>
<tr>
<td>Casing_male</td>
</tr>
<tr>
<td>Rotor_female</td>
</tr>
<tr>
<td>Interfaces</td>
</tr>
<tr>
<td>MGI01_Casing_female_Casing_male</td>
</tr>
</tbody>
</table>
Go to Geometry tree → Select **Rotor_male** and **Rotor_female**

Go to Results → Select Pressure

Create a monitor point at (0.0, 0.062, 0.203) for tracking Pressure history

While Point01 is active in the selection, Click → Add XY Plot → Select Pressure → Plot
Similarly create Plots for Mass Flux through the *suction_inlet* and *discharge_outlet* boundaries.

Save the project
5 Pumplinx Solver Calculation

▶ Go to Simulation tab ➔ Click Start

![Simulation Tab](image)

The time step size is controlled by the number of divisions used for angular discretization during grid generation in SCORG.

▶ Monitor the convergence in residuals:

![Convergence Graph](image)

▶ Pressure contours on the rotor profile can be seen updated by selecting the boundaries in geometric tree.
6 Summary

This document describes the steps to setup a Pumplinx model for Screw compressor CFD analysis starting from output data generated by SCORG™ Meshing tool. More detailed information on using SCORG and Screw compressor mesh generation can be found in user guide (SCORG, 2016). The Screw Module built in Pumplinx provides a very fast and user friendly setup procedure. It is possible to make quick changes in the grids and simply update the model by replacing the grid. The setup can be easily duplicated to users own port grids by editing the .spro file in an ordinary text editor. More detailed information on using Pumplinx, Transient simulations and Post-Processing can be found in user guide (Simerics, 2014)

7 Bibliography


End of Document