
Getting Started

Getting Started

If in Sketcher and Part Design you generated parts, now will learn how to finish  your design 
by assembling parts in Assembly Design workbench. 

Before  we discuss the detailed instructions for using the Assembly workbench, the following 
scenario aims at giving you a feel for what you can do with an Assembly document. You just 
need to follow the instructions as you progress.

The Getting Started section is composed of the following tasks:

Entering the Workbench
Fixing a Component

Inserting an Existing Component
Setting Constraints

Moving
Adding and Renaming a New Component

Designing a Part
Editing a Parameter

Replacing a Component
Analyzing Constraints

Reconnecting Constraints
Detecting Clashes

Editing a Component
Bill of Material

Exploding the Assembly

This scenario should take about 15 minutes to complete. 

Eventually, the assembly will look like this:
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Entering the Workbench

Entering Assembly Design Workbench

and Opening a CATProduct Document
This first task shows you how to enter Assembly Design workbench and how to open an existing 
product.

1. Select the Start -> Mechanical Design -> Assembly Design command to launch the required 
workbench. 

The workbench is opened. The commands for assembling parts are available in the toolbar to the 
right of the application window. For information on these commands, please refer to CATIA- 
Product Structure Version 5. 

You will notice that "Product1" is displayed in the specification tree, indicating the building block of 
the assembly to be created.
To know how to use the commands available in the Standard and View toolbars located in the 
application window border, please refer to CATIA- Infrastructure User's Guide Version 5.
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Entering the Workbench

2. Before following the scenario, set the following options:
make sure the option Work with the cache system is deactivated : use the Tools -> Options 
command, click Infrastructure -> Product Structure to the left of the dialog box that appears 
and uncheck the option "Work with the cache system". Do not forget to restart CATIA after 
turning off the cache. For more information, refer to Working with a Cache System.

use the Tools -> Options command, click Infrastructure -> Product Structure to the left of the 
dialog box that appears, then click the Product Structure tab and uncheck the option "Manual 
Input".  For more information, refer to Customizing Product Structure Settings.

use the Tools -> Options command, click Infrastructure ->Part Infrastructure to the left of the 
dialog box that appears, then check the option "Keep link with selected Object".  For more 
information, refer to Customizing General Settings.

 Note also that the default mode for the Update capability is "manual". For the purposes of this 
scenario, set the automatic mode.

3. Open GettingStarted.CATProduct. 

You will start the scenario with an existing assembly. Product1 is composed of three parts created 
in the Part Design Workbench:

1.  CRIC_FRAME (in turquoise) 
2.  CRIC_BRANCH_3 (in blue) 
3.  CRIC_BRANCH_1 (in red) 

From now on, these parts will be referred to as 'components'.
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Entering the Workbench

Surface and Coincidence constraints have been defined for these parts in the Assembly workbench.

4. Select Edit  -> Representations -> Design Mode. This mode lets you access technical data. 

5. Click the + sign to the left of the Constraints text  in the tree and apply the show mode on these 
constraints if you wish to view them in the geometry area.
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Fixing a Component

Fixing a Component
 This task shows you how to set the first constraint. This operation consists in fixing the 
position of a component in space so as to use this component as the base of the 
assembly.

1. Select CRIC_FRAME in the specification tree or in the geometry area.

2. Click the Fix Component  icon in the Constraints toolbar. 

The  component CRIC_FRAME is immediately fixed. The application indicates this by 
displaying a green anchor symbol on the component. 

Note also that the Constraints branch now displays the new constraint. The anchor 
symbol is preceded by a lock symbol, to make a distinction between "fix in space" 
and "fix operations". For more information, pleaser refer to Fixing a Component.
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Fixing a Component
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Inserting an Existing Component

Inserting an Existing Component
 This task shows you how to insert an existing component into the assembly.

 1.  Select Product1 in the specification tree.

2. Click the Existing Component  icon  in the Product Structure Tools toolbar. 

The File Selection dialog box is displayed.

3. Navigate to C:\Program Files\Dassault Systemes\B10doc\online\asmug
\samples directory and select Sub_Product1.CATProduct  

4. Click Open. 

A new component is added to the specification tree. The assembly now includes four 
components: three parts and a sub-assembly.
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Inserting an Existing Component

This is the component you have just imported:

 To know the different document types you can insert in a CATProduct document, 
refer to Product Structure Version 5. However, to know how to insert .asm 
documents properly, refer to Opening a .asm Document.
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Setting Constraints Between Components

Setting Constraints Between Components
 This task consists in setting a coincidence constraint, then a contact constraint between 
the component you have just inserted (Sub_Product1) and CRIC_BRANCH_1.

 1. Click the Coincidence icon  . 

A message window appears, providing information on the coincidence constraint 
command. If you do not want to see this dialog box appear any more, check Do not 
prompt in the future.

2. Select Axis in the geometry area. 

The application detects it once selected. The axis is now highlighted in the geometry.

3. Select one of the two inner faces of CRIC_BRANCH_1 to select the associated axis.
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Setting Constraints Between Components

As the coincidence constraint is created, CRIC_SCREW and CRIC_BRANCH_1 are 
aligned:

 

 
4. Now, you are going to set a contact constraint between CRIC_SCREW and a circular 

face of CRIC_BRANCH_1. 

To do so, click the Contact Constraint icon .
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Setting Constraints Between Components

5. Select the face as shown in the geometry area.

6. Select the red circular face in the direction 
opposite to the published face.

As the contact constraint is created, the turquoise cylinder is located exactly on the 
red face.

 
The created  constraints are automatically updated because the automatic update 
mode is activated. As the color defining valid constraints is green, our constraints are 
green. The application allows you to customize constraint colors as explained in 
Customizing Constraint Appearance.
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Setting Constraints Between Components

The assembly now looks like this:
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Moving

Moving Constrained Components Using the 
Compass 

 This task consists in manipulating the assembly to check if the components react the 
way we want, i.e. according to the constraints we set in the previous task.

 1. Select the red patch at the center of the compass and drag it onto CRIC_SCREW. For 
details about how to use the compass, please refer to CATIA- Infrastructure User's 
Guide Version 5.

As the compass is snapped to the component, you can manipulate the component.

2. Now, if you press and hold down the Shift key, select v/z axis on the compass, then 
drag and drop the component up and down, you can see that three components are 
moving. 

This is an example of what we can get:
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Moving

 

3. Repeat the operation as many times as you wish. 

The assembly reacts correctly. CRIC_FRAME does not move because it is fixed. 
The other three components can move.

4.  Release the left mouse button before releasing the Shift key.

5. Drag the compass away from the selected object and drop it.
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Adding and Renaming a New Component

Adding and Renaming a New Component
 This task consists in adding a new component to the assembly. You will then rename 
this component. This component is a part created in the Part Design workbench.

 1. Click Product1 and select the Part  icon in the Product Structure Tools toolbar.

The New Part: Origin Point dialog box appears, presenting two possible options: 
Either you define the point of your choice to locate the new part, or you use the origin 
point of the assembly as the origin point to be used for the part.

2. Click No to use the origin point of the assembly. 

The new component "Part5 (Part5.1)" is now displayed in the specification tree:
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Adding and Renaming a New Component

If the Manual Input option is activated (see Defining the Default Part Number), the 
Part Number dialog box appears before the New Part: Origin Point dialog box and 
lets you enter the name of your choice.

3. Right-click Part5 (Part5.1) and select the Properties... contextual 
command.

4.  In the Properties dialog box that appears. 

The options available in the Product tab let you enter the information you required.
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Adding and Renaming a New Component

5. Enter CRIC_JOIN.1 in the Instance name field and CRIC_JOIN in the Part Number 
field.

6.  Click OK to validate the operation. 

The new names are now displayed 
in the specification tree:
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Designing a Part

Designing a Part in an Assembly Context
 This task consists in designing the part you have just added to the assembly. It shows 
you how easy it is to access the tools required for designing components in an assembly 
context.

 1. Double-click CRIC_JOIN in the specification tree to access the Part Design 
workbench.

2. Select the blue face as shown and 
click the Sketcher icon  to access 

the Sketcher workbench.

3. Now that you are in the Sketcher, click 
the Normal View  icon in the 

View toolbar and sketch a circle on the 
face using the Circle command . 

Do not bother about positioning the 
circle.
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Designing a Part

4. Now to obtain the same radius value as the one used for CRIC_JOIN circular edge 
and to make sure that this circular edge and the circle share the same axis, use the 
Constraints Defined in Dialog Box command  to create a 

coincidence constraint (select the circle -if not already done- and the circular edge, 
then click the Constraint Defined in Dialog Box command and check 
"Coincidence").

After validating the operation, the circle 
is coincident with the circular edge. 
You must obtain this:
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Designing a Part

5. Exit the Sketcher and use the Pad command  with the "Up to Plane" option to 

extrude the sketched circle. Select the blue face as shown to specify the limit of the 
pad.

After validating the operation, you should obtain this cylinder: 

The part is designed.

For information about Part Design and designing in context, refer to CATIA- Part 
Design User's Guide Version 5  and Designing in Assembly Context respectively.
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Designing a Part
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Editing a Parameter

Editing a Parameter
 In this task, you are going to edit the diameter of the pocket belonging to 
CRIC_BRANCH_3. You will see how this edition affects the part you created in the 
previous task.

 1.  

2. 

Double-click CRIC_BRANCH_3 to access the Part Design workbench. 

Select Pocket.2 and use the Pocket.2 object -> Edit Parameters contextual command 
to display the associated parameters.

 

3. Double-click D11 in the geometry area to display the Constraint Edition dialog box.

4. Enter 20 as the new diameter value and click OK to generate the new pocket.
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Editing a Parameter

5. Update Product1 by double-clicking on Product1 in the specification tree.

The pocket is modified accordingly. The coincidence previously set between the two 
parts is maintained. 

This result is made possible thanks to the option Keep link with selected Object you 
set at the very beginning of the scenario.
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Replacing a Component

Replacing a Component
 This task shows you how to replace Sub_Product1.CATProduct by another component.

 1. Select Sub_Product1.CATProduct in the specification tree.

2. Click the Replace Component icon  in the Product Structure Tools toolbar.

3. In the dialog box that appears, select Sub_Product2.CATProduct as the 
replacement component and click Open. 

The Impacts on Replace dialog box is displayed:

4. Check Yes to replace all instances of the selected element and click OK to confirm.

Sub_Product1.CATProduct is no longer visible. This is Sub_Product2.CATProduct:
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Replacing a Component

If necessary update the document. 

Note that the coincidence constraint is maintained. This is due to the publication of 
the axis used in the constraint definition. As the axis is a published element, the 
application can reconnect the constraint.

Conversely, the contact constraint is broken. You will know how to reconnect it later.
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Analyzing Constraints

Analyzing Assembly Constraints
 This task shows you how to analyze the status of all assembly constraints defined for 
Product1.

 1.  Select the Analyze -> Constraints... command. 

The Constraints Analysis dialog box that appears displays all the information you 
need. The Constraints tab contains a detailed status of the assembly: the number of 
non-constrained components and the status of the defined constraints.

2. Click the Broken tab to see the list of broken constraints. We have only one broken 
constraint, a contact constraint.

3. Click on the name of the constraint. 

The constraint is highlighted in the specification tree.
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Analyzing Constraints

4. Click on OK to close the dialog box. 

Reconnecting this contact constraint is our next task.
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Reconnecting Constraints

Reconnecting a Broken Constraint
 In this task, you will learn how to reconnect the broken constraint detected by the application.

 1.  Double-click the broken constraint in the specification tree. Note that this broken constraint is 
indicated by a yellow warning symbol.

2. In the Constraint Definition dialog box that appears, click More to access additional information.

3. Click Disconnected in the Status frame, then Reconnect...

4.  You are then prompted to select a component to rebuild the constraint. Select the same faces as the 
ones used for setting the first contact constraint. If you need some help, refer to Setting Constraints 
Between Components.

5. Click OK to validate the operation and update the document. 

The constraint is reconnected:
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Reconnecting Constraints
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Detecting Clashes

Detecting Clashes
 In this task, you will learn how to detect possible clashes between two components.

 1. Select CRIC_BRANCH_1.1 in the specification tree.

2. 

Select the Analyze -> Compute Clash... command. 

The Clash Detection dialog box appears. It displays the first component selected for 
computing possible clashes.

3. As you need another component, select SUB_PRODUCT2 using the Ctrl key. 

This component also appears in the dialog box.

4. Click Apply to compute clashes. 

The application detects a clash between the brown cylinder and the red face. This is 
indicated by two red circles in the geometry, as the arrow shows in the figure below:
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Detecting Clashes

 

The result of the computation also appears in the dialog box.

5. Click Cancel to close the dialog box. 

Well, now that you know that your assembly needs to be modified to work properly, 
let's edit the cylinder.
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Editing a Component

Editing a Component
 This task shows you how to edit the component causing the problem.

 1.  Double-click the brown cylinder to access the Part Design workbench.

2. Double-click the cylinder again to edit it. The Pad definition dialog box is displayed.

3. Enter 20mm to reduce the pad length and click OK.

4. The cylinder is updated and now looks like this:
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Editing a Component
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Bill of Material

Displaying the Bill of Material
 This task shows you how to access all the information available about the structure of the 
assembly.

 1.  Return to Assembly Design workbench and select the Analyze -> Bill of 
Material... command.
The Bill of Material is displayed.
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Bill of Material

It is composed of these sections: 

Bill of Material: lists all parts and sub-products one after the other
Recapitulation: displays the total number of parts used in the product
Define formats: customizes the display of the bill of material

The Listing Report tab displays the tree of the product using indents

2. If you wish, you can save this document using the html format or the txt format. Just click the 
Save As... button, then give a name and the appropriate extension to your file.

For more information about the bill of material, refer to  Displaying the Bill of Material.
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Exploding the Assembly

Exploding the Assembly
 This last task illustrates the use of the Explode capability. Exploding the view of an 
assembly means separating the components of this assembly to see their relationships.

 1. Make sure Product 1 is selected.

2. Click the Explode icon   in the Move toolbar. 

The Explode dialog box is displayed.

Product 1 is the assembly to be exploded. The Depth parameter lets you choose 
between a total (All levels) or partial (First level) exploded view.

3. Set All levels if not already set.

4. Set 3D to define the explode type.

5. Click Apply to perform the operation. 

The Scroll Explode field gradually displays the progress of the operation. The 
application assigns directions and distance.

Once complete, the assembly looks like this:
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Exploding the Assembly

The usefulness of this operation lies in the ability of viewing all components 
separately. 

Note that you can move products within the exploded view using the 3D compass.

6. Click OK to validate the operation and then click Yes at the prompt or click Cancel to 
restore the original view.

Well, you have done all the tasks of the Getting Started section. Why not consult the 
rest of the documentation?
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Exploding the Assembly
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