
Getting Started

Getting Started
Before getting into the detailed instructions for using Generative Drafting, the following 
tutorial aims at giving you a feel of what you can do with the product. It provides a step-by-
step scenario showing you how to use key functionalities. The main tasks covered in this 
section are the following: 

Defining the Drawing Sheet
Opening a Part

Creating a Front View
Creating Projection Views
Creating a Section View
Creating a Detail View
Creating a Section Cut 

 

Before You Begin, make sure you customized the following settings: 

Grid:
De-activate the Grid icon  from the Tools toolbar (bottom right).

View names and scaling factors:
Go to Tools->Options (Mechanical Design -> Drafting option at the left of 
the dialog box, Layout tab) and un-check the View name and Scaling factor options.
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Getting Started

 This step-by-step scenario introduces the basic capabilities of Generative Drafting. You 
just need to follow the instructions as you progress along. 

At the end of this getting started, you will be able to print the following sheet:

 

 Before discovering this scenario, you should be familiar with the basic commands 
common to all workbenches. These are described in the  Infrastructure User's Guide.
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Defining the Drawing Sheet

Defining the Drawing Sheet
This task shows you how to define the drawing sheet to be used for creating the views 
described in further tasks.

1. Click the New icon  from the Standard toolbar or select 
File -> New... from the menu bar. 

 

2. Select Drawing workbench from the List of Types and 
click OK. 

3. 
 

From the New Drawing dialog box, select the ISO standard, 
and the A0 ISO format. 

In this particular case, and all along the guide, we use the 
ISO standard.

  

 

You can add an unlimited number of customized standards using Standard files that you will 
create and/or, if needed, modify. Once created, this standard will appear in the New Drawing 
dialog box. For more details on standards, see the Standards Administration section. Care 
that any user-defined standard is based on one of the four international standards (ANSI, ISO, 
ASME or JIS) as far as basic parameters are concerned.
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Defining the Drawing Sheet

4. 
 

In the Generative Drafting workbench, a grid is set by default. Throughout this 
documentation, we decided not to display the grid. To do this, de-activate the Grid icon  
from the Tools toolbar (bottom right).

The drawing sheet appears as shown here:

 

From now on, you will work on the created sheet unless you define a new sheet.
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Opening a Part

Opening a Part
 

This task will show you how to open the part to be used in the Generative Drafting 
workbench to create views. You may use either a 3D part or an assembly.

 

Before You Begin and all along the current Getting Started chapter, make sure 
you customize the following settings: 

Grid:
De-activate the Grid icon  from the Tools toolbar (bottom right).

 

1. Click the Open icon  from the Standard toolbar or select File->Open... from 
the menu bar. 

The File Selection dialog box appears.

2. 
 

Select the part to be opened. In this example, the user selects GenDrafting_part.
CATPart  document.
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Opening a Part

 

The part is opened and will remain displayed in the window whatever the views you 
will create from this part. 
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Opening a Part
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Creating a Front View

Creating a Front View
This task will show you how to create a front view on the sheet previously defined and from the 3D part you 
previously opened. 

 

At this step, we strongly advise that you tile screen horizontally . For this, go to Window -> Tile 
Horizontally options from the menu bar. 

 

If you do not want to have the specification tree displayed, press the PF3 key.

 

1. 
 

Click the Drawing window, and click the Front View icon  
from the Views toolbar (Projections sub-toolbar).

file:///C|/Documents%20and%20Settings/ako2001/My%20Doc...CATIAV5Tutorials/English/online/draug_C2/drauggs05.htm (1 of 3)06/11/2004 16:12:47



Creating a Front View

2. Select the desired planar surface of the 3D part you opened, 
from the 3D Part viewer.

 

Blue arrows and a green frame including a preview of the view to be created appear on the sheet.  

These frame and arrows allow defining the location and orientation of the view to be created.  

 
3. Click on the drawing sheet or at the center of the blue 

manipulator to generate the view.

As long as you see the green frame, you can define the 
frame position using the blue manipulators: top, bottom, left, 
right or rotated according to a given snapping, or else 
according to an edited rotation angle.

 

 

In the Generative Drafting workbench, the view name, scaling factor and view frame are set by 
default. Throughout this documentation, we decided not to display view names and scaling factors. For this:
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Creating a Front View

Go to Tools->Options->Mechanical Design->Drafting option (Layout tab) and un-check the 
View name and Scaling factor options.

 

The front view is created.

 

 

From now on, you will work on the created sheet unless you 
define a new sheet.

 

 

By default, a number of elements can be visualized on generated views. If needed, go to Tools-
>Options -> Mechanical Design -> Drafting option (Generation tab) to change this by un-
checking the required options. 
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Creating a Projection View

Creating a Projection View
This task will show you how to create projection views on the sheet.

 1.  Click the Drawing window and click the 
Projection View icon  from the Views toolbar 
(Projections sub-toolbar). 

  

A preview of the view to be created appears. By 
default, the projection view is aligned to the 
front view. 

As you move the cursor, a preview of the view 
to be created appears, as long as you keep the 
cursor positioned at any possible projection 
view location (at the left, right, top or bottom of 
the red frame). 

2.  Define the projection view position, for example 
the right view position, using the cursor.
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Creating a Projection View

Note that the left view shown here was created 
and therefore positioned according to ISO 
standards and the First Angle Projection 
method. For more information, please refer to 
Creating Views via the Wizard. 

 

 

3.  Click to generate the view.

4.  Click the Drawing window, and click the Projection View  using the cursor.

5. 

6. 

Define the top view position. 

Click at the left, right, top or bottom of the red 
frame to generate the view. 

The views result as shown here.
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Creating a Section View

Creating a Section View
This task will show you how to create a section view using the front view 
previously generated. 

This section view will make drawings more readable by replacing the hidden 
elements of parts including holes with filled areas.

 

1. Click the Drawing window, and click the 
Offset Section View icon  from the 
Views toolbar (Sections subtoolbar).

2. Select the holes and points required for sketching the callout on the view. 

Selecting a circular, a linear edge or an axis line (for example, a hole) amounts to 
making the callout associative by default to the 3D feature. If you select a circle, 
the callout will go through the circle center. If you select an edge, the callout will 
be parallel to the selected edge. 
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Creating a Section View

 

If you are not satisfied with the profile you create, you can, at any time, use Undo 

 or  Redo  icons. 

Note that SmartPick assists you when creating the profile. 

The section plane appears at the second point you select and moves dynamically 
on the 3D part as you create the callout on the drawing. This section plane will 
automatically disappear as you will double-click to end the callout creation.
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Creating a Section View
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Creating a Section View

  

3. Double-click to end the cutting profile creation.
Positioning the view amounts to defining the section view direction. The callout 
blue arrows direction is modified according to the cursor position. In other words, 
this preview behaves as if it were either a left or a right projection view you need 
to position.
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Creating a Section View

  

4. 

 

  

Click to generate the view. 

Using the cursor, you can then position the 
section view so that it is or not aligned to 
the front view.

 

You can modify the hatching pattern by pressing the right mouse button on the 
section view pattern and selecting the Properties option from the contextual 
menu. You will then display a Properties dialog box in which you will either 
select a new hatching pattern or modify the graphical attributes of the existing 
hatching pattern.
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Creating a Detail View

Creating a Detail View
This task will show you how to create a detail view from the front view you previously generated.

 1. Click the Drawing window, and click the Detail View 
icon  from the Views toolbar (Details subtoolbar).

2. 

3.  

Click the callout center. 

Drag to select the callout radius.

 

 

4. Click a point on the callout. 

A blue circle appears at the position of the cursor.

 

  

5.

  

Move the previewed detail view to the desired location.

6.  Click inside the blue circle to position the detail view at 
the desired location.
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Creating a Detail View

 7. If needed, drag the detail view to a new position.

 

  

As shown above, the scale by default is twice that of the active view. You can modify this scale. 
For this:
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Creating a Detail View

 8. Right-click the detail view and select the Properties option from the contextual menu, View 
tab, enter 4 as Scale and click OK. 

 

In this particular case, we will add a dimension to the detail view. For this: 

9. Click the  Dimensions icon  from the Dimensioning toolbar. 

 

10. Click both required elements in the view as shown here.

11. Enter 7mm as graphical value font size, in the Text Properties toolbar.

 

The dimension appears: 
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Creating a Detail View
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Creating a Section Cut

Creating a Section Cut
This task will show you how to create a section cut from the detail view you just 
created.
Be careful: the scale of the section cut will depend on the scale of the view this 
section cut is generated from. In this case, the section cut is generated from a 
detail with a scale 4: The section cut scale will also be 4.

1.  Right-click the detail view and select the Activate View option from the 
contextual menu.

2.  Select the Drawing window, and click the 
Aligned Section Cut icon  from the 

Views toolbar (Sections subtoolbar).

3.   Select the holes and points required for sketching the cutting profile.

Selecting a circular, a linear edge or an axis line (for example, a hole) amounts 
to making the cutting profile associative by default to the 3D feature.
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Creating a Section Cut

If you are not satisfied with the profile you create, you can, at any time, use 

Undo  or  Redo  icons. 

Note that SmartPick assists you when creating the profile. 

 
4.  Double-click to end the cutting profile creation. 

A preview with the view to be created appears. Positioning the section cut 
either to the right or to the left amounts to defining the section cut direction (as 
if it were a projection view). 

 
5.   Click to generate the section cut. 

 
Once you have clicked, you can modify position of the section cut relatively to 
the detail view on the condition you right-click the section view and select the 
Do not align views option from the contextual menu.
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Creating a Section Cut

You can select an existing edge within the view and define automatically the 
direction of the cutting profile. You can also select a reference plane in 3D or a 
3D wireframe plane. For more information, please refer to Creating an Offset 
Section Cut/Section View. 

 

 In this particular case, we will add a 
dimension to the detail view. For this:
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Creating a Section Cut

6. Add a diameter dimension to the section 
cut by clicking one edge only. 

In this case, we applied a higher font 
size to the dimension value.

You can modify the hatching pattern by pressing the right mouse button on the 
section cut pattern and selecting the Properties option from the contextual 
menu. You will then display a Properties dialog box in which you will either 
select a new hatching pattern or modify the graphical attributes of the existing 
hatching pattern. 

 

Now the resulting sheet is as shown here. Note that in this case, we re-
positioned the views. 
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Creating a Section Cut

 
You can now print this sheet. For this, select File -> Print from the menu 
bar. Make sure the print format of the current sheet is the same as the print 
format of the printer. 
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