
Getting Started

Getting Started
Before getting into the detailed instructions for using Interactive Drafting workbench, the following tutorial aims at giving 
you a feel of what you can do with the product. It provides a step-by-step scenario showing you how to use key 
functionalities. You just need to follow the instructions as you progress along. 

The main tasks described in this section are the following:

Entering the Interactive Drafting Workbench
Creating a New View
Creating a Rectangle

Creating Corners
Creating Lines

Translating Lines
Creating Circles

Creating Dimensions
Creating Annotations

 
Before discovering this scenario, you should be familiar with the basic commands common to all workbenches. These are 
described in the Infrastructure User's Guide.
All together, the tasks should take about 30 minutes to complete. 

The final drawing will look like this: 

 

 
 Set the options in Tools -> Options -> Mechanical Design -> Drafting: setting the options properly improves 

the software performances (see Customizing).
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Entering the Interactive Drafting Workbench

Entering the Interactive Drafting Workbench

This first task shows you how to enter the Drafting workbench and start a new drawing.

1. Select the File -> New command (or click the New  icon).

The New dialog box is displayed, allowing you choosing the type of the document you 
need. 

2. Select Drawing in the List of Types field and click OK. 

 
OR 

1. Select the Start -> Mechanical Design commands from the menu bar.

2. Select the Drafting workbench. 
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Entering the Interactive Drafting Workbench

OR 

1. Select the Tools -> Customize commands (Start Menu tab) and define the 
Favorites (Drafting) and Accelerator (F12) options as shown below and click 
the Close switch button.

2. Press F12  key or select the Start -> Drafting F12 commands from the menu 
bar. 
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Entering the Interactive Drafting Workbench

  

 

Whatever the dialog you used for entering the Drafting workbench you used, the New 
Drawing dialog box is displayed, allowing you choosing the type of Standard, Format, 
Orientation and scale you need.

 

3. Select the ISO standard and click the Landscape option.

If you activate the Hide when starting workbench option, the next time you enter the 
Drafting workbench via Start -> Drafting F12 or  by pressing F12 key, the New 
Drawing dialog box will not appear any more. Still, you will always be able to access this 
dialog box by selecting File -> New Drawing command from the menu bar.

4. Click OK. 
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Entering the Interactive Drafting Workbench

You can add an unlimited number of customized standards using Standard files that 
you will create and/or, if needed, modify. Once created, this standard will appear in 
the New Drawing dialog box. For more details on standards, see the Standards 
Administration section. Care that any user-defined standard is based on one of the 
four international standards (ANSI, ISO,ASME or JIS) as far as basic parameters 
are concerned.
You can create your own Format: 

key in the format name in the Format field,
use the tab key to access to the Width and Height fields and sets their 
values.

  

The Drafting workbench is loaded and an empty Drawing sheet opens:
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Entering the Interactive Drafting Workbench

Make sure you customized the units accordingly. For this: 

              1. Select the  Tools -> Options command to display the Options dialog box.

              2. Click General in the list of objects to the left of the Options dialog box.

              3. Select the Units tab and set Length to Inch and then click OK.
To visualize better your drawing, tile the windows horizontally from the menu bar.

The commands for creating and editing features are available in the workbench toolbar. 
Now to fully discover the Interactive Drafting workbench, let's perform the following tasks.
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Creating a New View

Creating a New View

In this task you will learn how to create a new view in the empty drawing you just opened 
using the Drafting Interactive workbench.

1. Click the New View icon  and click the Drawing sheet.

2. Click to position the new view. By default, this new view will be a front view.

In the following tasks, you will learn how to draw geometry in the empty view displayed 
which is by default a front view. In other words, you will draw geometry in this empty view 
and create both annotations and dimensions on this geometry.
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Creating a New View
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Creating a Rectangle

Creating a Rectangle

This task shows you how to define geometry in the newly created empty view which is by 
default, the front view. In this particular case, let's create a rectangle.
1. Click the Rectangle icon  from the 

Geometry creation toolbar (Profiles subtoolbar).

The Tools toolbar displays two value fields: horizontal value (H) and vertical value (V). 

The Tools toolbar displays not only command options but also given fields and values 
that appear in accordance with the command you select. This toolbar is situated at the 
bottom right of screen.
If you cannot see it properly, just undock it.

2. Enter the First Point coordinates. For example, H: 0in and V: 0in.

3. Press Enter.

At this step, you can either enter the rectangle second point or width and height values. 

4. Enter the Second Point coordinates. For example, H: 3.5in and V: 2.5in.

5. Press Enter to end the rectangle creation.
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Creating a Rectangle

The rectangle appears in the empty view.

You can also move the cursor for directly positioning the second point. The corresponding 
values similarly appear on the Tools toolbar. 

Note that the grid is not necessarily displayed throughout this documentation. Still, in the 
Generative Drafting workbench, the grid is set by default.  If you need to display the grid, go 
to Tools->Options (Drafting/General) and check the Display option.
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Creating Corners

Creating Corners

This task shows you how to create corners on an existing rectangle by multi-selecting 
points. 
1. Multi-select the rectangle 
endpoints.

2. Click the Corner icon  from the 
Geometry Modification toolbar 
(Relimitations subtoolbar).

The Tools toolbar displays with a Radius field:

3. Enter a radius value in the Tools toolbar. For example, Radius: 0.25in. 

4. The four corners are automatically 
created with the same radius value.

If you want to create the corners one 
after the others, you can also select 
the Corner icon first and then click 
the geometry.
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Creating Corners

  

file:///C|/Documents%20and%20Settings/ako2001/My%20Doc...CATIAV5Tutorials/English/online/driug_C2/driuggs05.htm (2 of 2)06/11/2004 16:14:11



Creating Lines

Creating Lines
 In this task you will learn how to create a line.

 1. Click the Line icon  from the 

Geometry creation toolbar.

The Tools toolbar displays with the Start Point value fields:

2. Enter the line Start Point coordinates. For example, H: 1.625in and V: 0in.

3. Press Enter.

4. Drag the cursor to the desired location for creating the second line point. For 
example, drag the line end point to the top rectangle horizontal line.

In this particular case, smartpicking is used 
for creating the line. In other words, you 
want the line to be parallel with one of the 
rectangle lines. 

The parallelism symbol  appears as 
shown here.
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Translating Lines

Translating Lines

This task shows you how to translate a line. In this particular case, we will also duplicate the line to 
be translated.
1. Select an element. For example, a line. 

2. Click the Translate icon  from the Geometry 
Modification toolbar (Transformations subtoolbar).

 

 

 

The Translation Definition dialog box 
appears and the Start Point value fields (H and 
V) appear in the Tools toolbar. 

 

3. The Duplicate mode option (Translation 
Definition dialog box) is activated, by default. If 
not, activate this mode.

4. Enter the duplicated line Start Point coordinates in the Tools toolbar. For example, H: 
1.7in and V:0in.

5. Press Enter.

6. Enter the duplicated line End Point coordinates in the Tools toolbar. For example, H: 2in 
and V:0in. 
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Translating Lines

 

OR

5. Enter a length for the line in the Value field. For 
example, 0.3in.

The Snap Mode is automatically deactivated.

6. Click OK to validate.

7. Once you are satisfied with your operation, click 
on the view. 
The second line is created.

 

This is the resulting translated line. 

A new line is created and translated according to the existing one. 

Proceed in the same manner to create the third, fourth, fifth and sixth lines. The process described 
above is valid for any other line to be created with the Translation command in our context.

Select two lines at a time to perform your translation, it is time-saving.
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Translating Lines

Your final drawing will look like this:

You can also select the Translate icon  first and then the geometry to be translated.
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Creating Circles

Creating Circles

This task shows you how to create circles and circle centers using coordinates.

1. Select the Circle icon  from the Geometry creation 

toolbar.  

 

The Tools toolbar displays circle value 

fields.

2. Enter the Circle Center coordinates. For example, H: 0.75in and V: 2in.
3. Press Enter. 

4. Enter the circle radius. For example, R: 0.375in.
5. Press Enter. 
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Creating Circles

6. Repeat the scenario to create the second circle using the same circle radius values. 

 

Now, let's create inner circles. For this: 

7. Click again the Circle icon .

8. Select the existing circle center. 
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Creating Circles

9. Enter the center circle radius. 

10. Press Enter. 

11. Repeat the scenario to create the second inner circle. 

This is what you obtain:
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Creating Circles

You can also select the geometry to be translated first and then the Translate 
command .

You can then translate the circles newly created and get the following result:
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Creating Dimensions

Creating Dimensions

This task shows you how to add dimensions to the geometry you previously created.

1. Click the Dimension icon  from the Dimensioning toolbar. 

 

2. Click a first element in the view. For example, the rectangle top line.

At this step, a dimension appears (length dimension). This dimension is defined 
according to the element first selected. You can either accept the dimension (click in 
the free space) or select another element (for creating a distance dimension).
3. Click a second element in the view. For example, the rectangle bottom line.
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Creating Dimensions

4. If needed, drag the dimension to the desired location.

At this step, you can apply various modifications to the dimension you are creating. 
You can: 

modify the dimension overrun/blanking using manipulators or the Ctrl key to 
modify only one extension line.
add text before or after by double-clicking the dimension
redefine the dimension properties using the required toolbar:
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Creating Annotations

Creating Annotations
This task shows you how to add annotations on your drawing. In this particular case, we 
will add text to existing 2D elements.
1. Click on an icon from the Annotations 
toolbar. 

For example, click the Text icon .

2. Click an element. 

The text will be positioned according to 
this element.

3. Enter the required text in the Text 
Editor dialog box.

As you type in, the text appears in the graphic Text Editor window.

4. If needed, drag the text to the desired 
location.
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Creating Annotations

The annotation will now remain associated to the selected 2D element. In other words, 
each time you move the 2D element, the associated annotation moves accordingly.
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