
Getting Started

Getting Started
This tutorial will guide you step-by-step through your first ELFINI and Generative Part 
Structural Analysis session, allowing you to get acquainted with the product. You just 
need to follow the instructions as you progress.

Entering the Generative Structural Analysis Workbench
Creating a Surface Slider Restraint
Creating a Distributed Force Load
Computing a Static Case Solution
Viewing Displacements Results

Inserting a Frequency Analysis Case
Creating an Iso-static Restraint
Creating a Non-Structural Mass

Computing a Frequency Case Solution
Viewing Frequency Results 

  

 These tasks should take about 20 minutes to complete.

file:///C|/Documents%20and%20Settings/ako2001/My%20Documen...rse/CATIAV5Tutorials/English/online/estug_C2/estuggs00.htm06/11/2004 16:15:26



Entering the Structural Analysis Workbench and Selecting a Part

Entering the Structural Analysis Workbench 
 This first task will show you how to load a .CATPart document (and display the 
corresponding specification tree) by entering the Generative Structural Analysis 
workbench and defining that you will create a Static Analysis case. 

Creating a static analysis case means that you will analyze the static boundary 
conditions of the CATAnalysis document one after the other.

 

 Before you begin:  
Note:
In this example, a material has been previously assigned to the part you will 
open. In the case no material has been previously assigned to the part, before 
entering the Generative Structural Analysis workbench, you should proceed 
as follows:

1.  Select the part in the specification tree. 
2.  Click the Apply Material icon  .

The Material library appears. 
3.  Select a material family, then select the desired material from the 

displayed list, then click OK.
The material is applied. 

You can visualize the material properties and its analysis characteristics by 
selecting the material in the specification tree and using Edit -> 
Properties -> Analysis. 

If you select Start->Analysis & Simulation -> Generative 
Structural Analysis from a CATPart document containing a part 
without any material assigned, the material library will appear directly for an 
easy material selection. 

Warning:
Avoid having CATAnalysis documents automatically saved. For this, go to 
Tools->Options->General (menu bar) and de-activate the Automatic 
save every xx minutes option. Otherwise, on some models, each 
computation will be followed by a Save, thus making temporary data become 
persistent data.
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Entering the Structural Analysis Workbench and Selecting a Part

 
  

 

Open the CATPart Document

1. Select File -> Open, then select the desired .CATPart file. In this tutorial, you will 
open CATPart named sample01.CATPart.

This opens a Part Design document containing the selected part.

 

Define the View Mode

2. Select View -> Render Style -> Customize View option from the toolbar and 
activate the Materials option from the displayed Custom View Modes dialog box.
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Entering the Structural Analysis Workbench and Selecting a Part

Enter Generative Structural Analysis Workbench

3. Select Start -> Analysis & Simulation -> Generative Structural 
Analysis from the menu bar.

 

The New Analysis Case dialog box appears with Static Analysis as default type.

file:///C|/Documents%20and%20Settings/ako2001/My%20Doc...CATIAV5Tutorials/English/online/estug_C2/estuggs01.htm (3 of 6)06/11/2004 16:15:40



Entering the Structural Analysis Workbench and Selecting a Part

 

Static Analysis  means that you will analyze the static boundary 

conditions of the CATAnalysis document one after the other. 

Frequency Analysis means that you will analyze the dynamic boundary 

conditions  of the CATAnalysis document .

Free Frequency Analysis means that you will analyze the buckling 

dynamic conditions of the CATAnalysis document. 

Keep as default starting analysis case means that when you next open the 
Generative Structural Analysis workbench from the menu bar, the selected 
case appears as default. 
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Entering the Structural Analysis Workbench and Selecting a Part

4. If needed, select an Analysis Case type from the New Analysis Case dialog box.
In this particular case, also keep Static Analysis type selected. 

5. Click OK in the New Analysis Case dialog box to enter the workbench. 

The CATAnalysis document now opens. It is named Analysis1. You will now 
perform different operations in this document. 

A link exist between the CATPart and the CATAnalysis document. 

 

 Double-clicking on the green symbol allows displaying mesh specifications or setting 
meshing parameters.  

The standard structure of the Analysis specification tree is displayed. 

As you can see below, the Finite Element Model contains a Static Case, which 
contains empty Restraints and Loads objects sets, along with an empty Static 
Case Solution.1 object set. All along this tutorial, you will assign a Restraint and a 
Load to the CATAnalysis document and then compute the Static Case Solution. 
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Entering the Structural Analysis Workbench and Selecting a Part
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Creating a Surface Slider Restraint

Creating a Surface Slider Restraint
 This task will show you how to restrain several faces of your part in such a way that it 
can only slide along their tangent planes (geometry supports). You will create a surface 
slider restraint on a Finite Element Model containing a Static Analysis Case. 

 

 1. Select the Restraints.1 object in the specification tree to make it active. 

 

2. Click the Surface Slider icon  . 

The Surface Slider dialog box appears.
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Creating a Surface Slider Restraint

3. Select in sequence the four faces as indicated. 

 
Symbols representing the surface sliders appear as you select the four faces. The 
elements supporting the surface slider are automatically displayed in the Surface Slider 
dialog box.

4. Click OK in the Surface Slider dialog box to actually create this surface slider. 

In the specification tree, the Surface Slider.1 object has been inserted under the 
Restraints.1 object. 
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Creating a Surface Slider Restraint
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Creating a Distributed Force Load

Creating a Distributed Force Load
 This task will show you how to distribute on a face of your part a resultant force. You will 

create a Distributed Force on a Finite Element Model containing a Static Analysis Case. 

 
 1. Select the Loads.1 object in the specification tree to make it active. 

 

2. Select the Distributed Force icon  . 

The Distributed Force dialog box appears. 

You will distribute on a face of your part a resultant force of 50N parallel to the global z-
direction applied at the centroid of the face. For this:

3. Enter -50N value in Z  field (Force Vector).

The resultant Force Vector Norm field is automatically updated. 
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Creating a Distributed Force Load

 

4. Select the part face as indicated below.
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Creating a Distributed Force Load

A symbol (arrow) representing the Distributed Force is displayed.

5. Press OK in the Distributed Force dialog box to create the Distributed Force. 

The Distributed Force.1 object has been inserted under the Loads.1 objects set 
in the specification tree. 
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Computing a Static Case Solution

Computing a Static Case Solution 
 This task will show you how to compute the Static Case Solution of a Finite Element 

Model on which you previously created a Restraint object and a Load object. You will 
store the results in a given directory. 

 

1. Select the Storage Location icon .
The Current Storage Location dialog box is displayed. 

2. If needed, change the path of the Result Data and/or Computation Data 
directories and then click OK in the Current Storage Location dialog box. 

 

The Results and Computation Data are stored in one single file with given extensions: 
xxx.CATAnalysisResults
xxx.CATAnalysisComputations

3. Select the Compute icon  .
The Compute dialog box appears.
The Current Storage Location dialog box disappears.
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Computing a Static Case Solution

 

4. Select the All default value proposed for defining which are the objects sets to be 
updated.

5. Click OK in the Compute dialog box to launch the computation.

 

The Progress Bar dialog box provides a series of status messages (Meshing, 
Factorization, Solution) that inform you of the degree of advancement of the 
computation process.
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Computing a Static Case Solution

Upon successful completion of the computation, the status of all objects in the 
analysis specification tree up to the Static Case Solution.1 objects set is 
changed to valid. In other words, the   symbol appears no more.

The color change of the Restraints and Loads symbols to blue, also reflecting the fact 
that the Static Case Solution computation was successful. 
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Computing a Static Case Solution
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Viewing Displacements Results

Viewing Displacements Results 
This task will show you how to visualize the displacements of the CATAnalysis according to the restraints and 
load you assigned to this CATAnalysis. You previously launched the computation of the Static Analysis Case 
and will now generate a Report with computations of the displacements you are going to perform: 

Displacement 
Stress Von Mises

 

1. Click the Displacement icon  .  

A plot of the displacement field is displayed with arrow symbols. If you go over the plot with the cursor, you 
can visualize the nodes. The computed displacement field can now be used to compute other results such as 
strains, stresses, reaction forces and so forth. 

 
Arrows representing the displacement: Zoomed arrows: 
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Viewing Displacements Results

2. Click the Stress Von Mises icon  .  

Go to View -> Render Style -> Customize View and make sure the Materials option is active in 
the Custom View Modes dialog box.

Both a Translational displacement vector image object and a Von Mises Stress (nodal 
value) image object appear in the specification tree under the Static Case Solution.1 objects set.

You can choose to have both Translational displacement vector and Von Mises Stress 
(nodal value) deformed mesh displayed. For this, right-click on Translational displacement 
vector in the specification tree and select the Activate/Deactivate option that is displayed in the 
contexual menu. 
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Viewing Displacements Results

3. Double-click the Von Mises Stress feature in the specification tree to edit the image. 

The Image Edition dialog box appears.
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Viewing Displacements Results

Color value: 
The Color Palette enables you to modify the color distribution and to focus on specific values.

For more details on this functionality, refer to the task Editing the Color Palette.

 

Internal von Mises stress field values
To visualize internal von Mises stress field values in a plane section through the part, click the Cut 
Plane Analysis icon  .
You can handle the compass with the mouse in order to rotate or translate the Cutting Plane (to do so, 
select an edge of the compass and drag the mouse).
To exit this view, click CLOSE in the Cut Plane Analysis dialog box that appeared.
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Viewing Displacements Results

 

4. Click the Search Image Extrema icon   to obtain local and global extrema values of the von Mises 
stress field magnitude. 

The Extrema Edition dialog box appears. 

 

Click OK once you have defined the number of the extrema you need. In this particular case, you will define 
that you need two Absolute extrema.

 

Locations of the global maxima and minima are indicated on the image, and the Extrema object appears in 
the specification tree under the Static Case Solutions objects set.   
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Viewing Displacements Results

As you can see above, the values are not satisfying for our static case: you need more distributed force so 
that the Stress Von Mises values might be more significant. You will therefore save the document, modify the 
values and re-compute the static case in the following task.
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Inserting a Frequency Analysis Case

Inserting a Frequency Analysis Case 
 This task will show you how to insert a Frequency Analysis Case using the CATPart 
document called sample01.CATPart. 

Creating a frequency analysis case means that you will analyze the dynamic boundary 
conditions  of the CATAnalysis document.

 

 Before you begin:
Remember that we use the Materials view mode. If needed, go to View -> Render 
Style -> Customize View option from the toolbar and activate the Materials 
option from the displayed Custom View Modes dialog box. 

 
 1. Select Insert -> Frequency Case from the menu bar.
The Frequency Case dialog box appears with the possibility to either use the existing 
Analysis case as Reference or create a Frequency case with New feature. 

2. Click OK. 

A new Analysis solution and the standard structure of Analysis specification tree is 
displayed.
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Inserting a Frequency Analysis Case

 

The Finite Element Model contains a Frequency Case, which contains empty Restraints 
and Masses object sets, along with an empty Frequency Case Solution.1 object 
set.  

 Remember that if you selected Start->Analysis & Simulation -> New 
Generative Analysis from a CATPart document containing the part without any 
material, the material library will appear directly for an easy material selection.
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Creating an Iso-static Restraint

Creating an Iso-static Restraint
 This task will show you how to create an Iso-static Restraint on a part. In other words, 

you will apply statically definite restraints allowing you to simply support a body.  

 

 1. Select the Restraints.2 object in the specification tree to make it active. 

 

2. Click the Isostatic Restraint icon  .
The Isostatic Restraint dialog box appears. 

 
You will restrain your part in such a way that it is statically definite and all rigid-body 
motion is impossible. The program will automatically determine the restrained points 
and directions. 
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Creating an Iso-static Restraint

3. Click OK in the Isostatic Restraint dialog box to create the Iso-static Restraint. 

The Isostatic symbol appears on the part.

 

The Iso-static Restraint object (Isostatic.1) has been inserted under the 
Restraints.1 objects set in the specification tree. 
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Creating an Iso-static Restraint
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Creating a Non-Structural Mass

Creating a Non-Structural Mass
 This task will show you how to create a Mass Surface Density on the surface geometry 

supports. In this example, you will distribute a mass density of 50kg/m2 on several 
faces of your part.  

 

 1. Select the Masses.1 objects set in the specification tree to make it active. 

 

2. Click the Surface Mass Density icon  .
The Surface Mass Density dialog box appears. 
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Creating a Non-Structural Mass

3. Select the faces on which you will distribute a mass density.
Red symbols representing the Mass Surface Density are displayed. 

4. Enter a new Mass Density in the Surface Mass Density dialog box. In this 
particular case, enter 50kg_m2. 

 

5. Click OK in the Surface Mass Density dialog box.
The Surface Mass Density.1 object is now inserted under the Masses.1 object 
set in the specification tree. 
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Creating a Non-Structural Mass
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Computing the Frequency Case Solution

Computing the Frequency Case Solution 
This task will show you how to compute a Frequency Case Solution on which you 
previously created a Restraint object and optionally a Mass object. 

 

1. Click the Storage Location icon .
The Current Storage Location dialog box is displayed.  

 

Optionally change the path of the External Storage directory to another directory and 
then click OK in the Current Storage Location dialog box. 

 
 The results and computation data are stored in one single file with given extensions: 

xxx.CATAnalysisResults
xxx.CATAnalysisComputations

  

2. Click the Compute icon  .
The Compute dialog box appears.
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Computing the Frequency Case Solution

 

Take the default (All) proposed for the objects sets to update.

3. Click OK to perform the computation. 

The Progress Bar dialog box provides a series of status messages (Meshing, 
Factorization, Solution) that inform you of the degree of advancement of the 
computation process.
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Computing the Frequency Case Solution

Upon successful completion of the computation, the status of the Frequency Case 
Solutions objects set is changed to valid in the specification tree. In other words, the   
symbol appears no more. 

Note the green color change of the Restraints and Masses symbols, reflecting the fact 
that the Frequency Case Solution computation was successful.  
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Viewing Frequency Results 

Viewing Frequency Results 
 This task will show you how to visualize Vibration Modes after computing the Frequency 
Analysis Case and how to generate a Report. 

 

1. Click the Deformation icon .  

An image of the deformation corresponding to the first vibration mode is displayed, and 
the Deformed Mesh image object appears in the specification tree under the 
Frequency Case Solution.1 objects set.
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Viewing Frequency Results 

2. Double-click the Deformed Mesh object in the specification tree to edit the image.  

The Image Fem Editor dialog box, containing the list of vibration modes with the 
corresponding frequency occurrences is displayed. You can visualize any mode by 
clicking it in this multi-occurrence list. 

3. Click the seventh mode in the multi-occurrence list, for example. 

file:///C|/Documents%20and%20Settings/ako2001/My%20Doc...CATIAV5Tutorials/English/online/estug_C2/estuggs11.htm (2 of 4)06/11/2004 16:16:57



Viewing Frequency Results 

  

The selected mode is displayed. 

 

4. Once you have finished editing images, click OK in the dialog box. 
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Viewing Frequency Results 

You can further manage your results by using the Results Management action 
icons on the bottom of your screen. 
For more details, please refer to Results Visualization. 
In addition to standard information, the Report for a Frequency Case Solution 
contains modal participation factors information, which allows you to evaluate the 
validity of the modal truncation to the first 10 modes. 
You can modify the number of computed modes by double-clicking the Solution 
and editing the Solution Definition dialog box.
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